docker plex no thumbnails on videos, beginner question

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • docker plex no thumbnails on videos, beginner question

      I maybe have a stupid question. I have moved from using the plex plugin to using plex in docker. the problem I am having is that the thumbnails for my videos are not generating on the plex docker version?

      have tried to follow the offical plex guide but that didnt help.:
      support.plex.tv/articles/202197528-video-preview-thumbnails/

      the oddest thing was that it worked nicely after a reinstall of the image but then I got thrown off the server and had to make a new serven that didnt generation thumbnails.

      so maybe it is a hardware issue?
      the data is on 2 HHD, the /transcode, /data and /config is on a usb stick. the HDD was very noisy if they had those folders so that is the reason. the PUID and PGID is both set to 1000.
      I am running it on a Rock64pro 4gb ram.

      I read here that one solution could be that the Plex is not running in root? but I am not sure if that is a possibly if it is install from docker
      forums.plex.tv/t/solved-video-…nerating-update/154382/36

      I also found this article about forcing plex to create thumbnails but I am not sure if I am doing it wrong (I probably am)
      forums.plex.tv/t/force-thumbnail-update/18855

      I could copy the code below into the "run cmd" button in docket but it just fail.

      but in the forum the author also mention "Adjusting for your section number of course" so should the "section 1" below be changed to the name of the folder that need to be scanned ?

      Source Code

      1. "Plex Media Scanner" --generate --section 1
      but I hope someone can help me since I am getting desperate.

      thanks.
    • Are you sure you really want video preview thumbnails? Do you have enough disk space where the /config is located?

      I used to have video preview thumbnail generation enabled, but I discontinued this after the Plex metadatabase reached 220GB. <---Not a typo, 220GB.

      Also, if you do want to do this you should be aware that thumbnail generation for newly added media happens immediately. But thumbnail generation for existing media files happens in the background at a low priority and can take a very very long time to complete. That process, once started on what I consider a large media library, ran 24/7 for more than two months on my OMV server.
      --
      Google is your friend and Bob's your uncle!

      RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.

      ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.
    • Hello gderf

      Yes I am sure, my collection (if that is the right English word) isn’t that big. I notice when the docker plex shortly generated the thumbnails, that each picture that was stored on the hdd was around 50kb so it wouldn’t be a problem for me storage wise.

      Does the plugin plex also create a picture? I never notice it doing that before. Maybe it create a temporary folder for those pictures?

      Well time wouldn’t be a problem, last time I used the plex plugin I used less that 20 min to generate all the thumbnails on the same hardware.

      The reason I switch to docker, was that the plugin started to crash. I could watch on mp4 and then when I switch to another video then the connection to the serve would go offline. And when I tried to reinstall the plugin it said there was a lack of resources. Maybe it is a plex update related? Seems to be many forums talking about a new update to plex that are a bit off setting. Or maybe I misread something somewhere.

      edit: now the server also go offline after trying to play “next video”, in docker. So I hope my hardware is not failing.

      edit 2: So I got it working now, I cant explain what i did. The only thing I did different was a fresh reinstall and I have made 5 reinstall in this process with plex always failing. Maybe, just maybe, It could be that I had plex install in both he docker and plugin at the same time (not running at the same time) or maybe some other factors that I cant seem to understand. I am terrible sorry for the inconvenient of this topic since the solutions was just trying to mass fresh install. sorry again.

      The post was edited 3 times, last by Chrisjay ().