Web UI won't log me in!

  • Hey folks.

    I've been having an issue recently where the Web UI won't log me in. If I input an incorrect password, it recognises that and prompts me to enter the correct password however if i enter the correct password the page try's to load but chucks me back to the login page like the page has refreshed. I've screen recorded whats happening if that's any help.

    Thanks folks

  • Enter with ssh check the rootfs is not full with df -hIf the rootfs is not full, the try the browser in private mode.

    Thanks subzero79. rootfs was only using 1% so tried the private browsing and that worked :-) Cleared cookies etc and now working as normal again. Thanks dude!

  • Hi! I'm new on this forum.
    I've seen the topic has the status "solved" but as it's the same password issue I try to put this message here!
    I'm technician in a computer company and we sold several servers using OpenMediVault for NAS storage.

    The customer has the same issue as above (wrong password > says password is wrong; good password > no connection and login page refresh).
    He has several servers with the same OpenMediaVault installation and with the same update packages. The issue happens only for one of the servers.

    After doing the recommanded commands shown above it appears that :
    - Using a private browsing session don't change anything
    - A df -h shows rootfs is full (100% - 1.8GB / 1.8GB used)

    Doing a du -ch shows a total of 447MB used (size of a typical OpenMediaVault installation). So there is no big log lifes or else who fill up the rootfs filesystem.
    I saw elsewhere that it can be related to mounting points but all seems normal in this case.

    Do you have any idea from where this problem comes and how to solve it?

  • du -ch against / who is the mounting point for rootfs.
    The last line shows the total for the space filled on /
    I knew there is surely better option to use along with du but I was in a hurry and found that one!

    How can you explain that a du command on / can report a 447MB total space occuped and a df -h can find 1.8GB total space occuped (so more than one extra GB)?

  • du is reporting files, df is reporting file system. The whole explanation is here http://linuxshellaccount.blogs…lay-different-values.html

    Go to the /media folder, unmount all the drives, and check if any files are remaining there, sometimes happens that drives are disconnected from the system and another process writes to the path of /media filling the OS drive. Very common problem

  • Thanks for this interesting link.

    As I've said before there are no other storage peripheral mounted (like a USB key or something else), and nothing is mounted in /media...
    ... But there are some tmpfs filesystems mounted (sum of them = 1241MB)
    As rootfs take 477MB for OS we have 477+1241=1691MB used (so nearly the 1.8GB of the SATA DOM used for the Operating System).

    So theses tmpfs filesystems are sub-mounting points of rootfs and that's why rootfs is full, am I right?.

    Here is the output of the df -lh command :

    FS Size Used Avail Use% Mount

    rootfs 1,8G 1,8G 0 100% /
    udev 10M 0 10M 0% /dev
    tmpfs 394M 784K 394M 1% /run
    /dev/disk/by-uuid/dca44a4b-9be6-4b50-8aff-968c2b79ada6 1,8G 1,8G 0 100% /
    tmpfs 5,0M 0 5,0M 0% /run/lock
    tmpfs 814M 0 814M 0% /run/shm
    tmpfs 2,0G 1,1M 2,0G 1% /tmp
    /dev/md0 22T 7,1T 15T 33% /media/83943962-7ed4-426a-bdd0-faa1f039910f

    If I'm right, is there a way to properly remove the files contained in these tmpfs filesystems?
    I suppose it contains only temporary files who weren't removed when becoming unused but correct me if I'm wrong!

  • Well, the problem seems temporary solved!

    After checking the result from du --max-depth=1 -xh / on the problematic server and a good one it appeared that :

    Problematic server /var size : 1.1GB
    Good server /var size : 100MB

    It was caused by these kind of log files who where too big :
    mail.log.1 : 196 MB
    mail.info.1 : 196 MB
    mail.log : 153MB
    mail.info : 153 MB

    The customer removed them and now web interface connection is now possible!
    I asked him for the logs but I'm not sure he did a copy of these logs files for further investigation...

    Anyway thanks for your help! :thumbsup:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!