Cannot Mount FileSystem After Building Raid5

  • Hi,


    I'm new to OMV (Version 2.1.17). I Googled for this issue and also check this forum but the solutions offered did not solve my problem. What I did step by step is,


    1. Wiped my all 3 physical disk (all of 3 are same products) securely. (Took about 9 hours)
    2. Built a software Raid5
    3. Created a ext4 filesystem belonging to my Raid5.


    During this period, everything was ok and with no error messages. But, the mount button in filesystem menu is still disabled. I tried all the filesystems too... I tried to mount the raid via bash, but still can't be able to change the state of mount button.


    I need your advice. I can an ssh connection for you to check also...


    Thanks,

    • Official Post

    What is the output of:


    cat /proc/mdstat
    blkid

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • The output is below;



    root@BMNAS:~# cat /proc/mdstat


    Personalities : [raid6] [raid5] [raid4]


    md0 : active raid5 sda[2] sdb[1] sdc[0]


    1953262592 blocks super 1.2 level 5, 512k chunk, algorithm 2 [3/3] [UUU]



    unused devices: <none>


    root@BMNAS:~# blkid


    /dev/sdh1: UUID="82405458-e9c5-4cf9-937b-9d596b118946" TYPE="ext4"


    /dev/sdh5: UUID="641c3788-8d90-4b07-8c28-2ec980384239" TYPE="swap"


    /dev/sdb: UUID="81471f15-f04c-21ac-a345-1b172caa27f3" UUID_SUB="8577de0e-a063-184d-b10a-ed568ba73fe9" LABEL="BMNAS:BMRAID5" TYPE="linux_raid_member"


    /dev/sda: UUID="81471f15-f04c-21ac-a345-1b172caa27f3" UUID_SUB="7d55a8fc-148f-7dda-b7e0-162560c62328" LABEL="BMNAS:BMRAID5" TYPE="linux_raid_member"


    /dev/sdc: UUID="81471f15-f04c-21ac-a345-1b172caa27f3" UUID_SUB="1b59316c-79bb-3d2c-e793-4e9c5ff8100b" LABEL="BMNAS:BMRAID5" TYPE="linux_raid_member"


    /dev/md0: LABEL="BMRAIDVOL" UUID="88d971e6-866f-4f4b-bde3-22c6fdcd358f" TYPE="ext4"

    • Official Post

    What about:


    cat /etc/fstab
    mount /dev/md0

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • It responded like this;


    • Official Post

    According to the output, OMV doesn't know about the filesystem on the array yet. Try the following (assuming there is no data on the array):


    dd if=/dev/zero of=/dev/md0 bs=512 count=10000
    mkfs.ext4 /dev/md0


    Then try to mount in the filesystems tab.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Mount button is still disabled :(


    Here is the output of the last operation;


    root@BMNAS:~# dd if=/dev/zero of=/dev/md0 bs=512 count=10000


    10000+0 records in


    10000+0 records out


    5120000 bytes (5,1 MB) copied, 1,7325 s, 3,0 MB/s


    root@BMNAS:~# mkfs.ext4 /dev/md0


    mke2fs 1.42.5 (29-Jul-2012)


    Dosya sistemi ismi =


    OS type: Linux


    Blok boyu = 4096 (günlük kaydı = 2)


    Adımlama boyu = 4096 (günlük kaydı = 2)


    Stride=128 blocks, Stripe width=256 blocks


    122085376 inodes, 488315648 blocks


    24415782 blocks (5.00%) reserved for the super user


    İlk veri bloğu = 0


    Azami dosyasistemi bloğu sayısı = 0


    14903 blok grubu


    Grup başına 32768 blok ve 32768 sekme


    grup başına 8192 düğüm


    Süperblokların bulunduğu bloklar:


    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,


    4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,


    102400000, 214990848


    Allocating group tables: bitti


    Düğüm tabloları yazılıyor: bitti


    Creating journal (32768 blocks): tamam


    Süperblokların ve dosya sisteminin hesap bilgileri yazılıyor: bitti


    root@BMNAS:~#

  • I installed it on a clean flash disc with the openmediavault_2.1_i386.iso burned cd. I haven't done any customization during the install. I made secure wipe to all my 3 hdd and then built the raid5. Here is what i did after your last reply.


    root@BMNAS:~# mkdir /mnt/md0


    root@BMNAS:~# mount /dev/md0 /mnt/md0


    root@BMNAS:~# /dev/md0 /mnt/md0 ext4 auto,users,user_xattr 0 2


    -bash: /dev/md0: Access Denied



    root@BMNAS:~# mdadm --examine --scan >> /etc/mdadm/mdadm.conf


    root@BMNAS:~# /dev/md0 /mnt/md0 ext4 auto,users,user_xattr 0 2


    -bash: /dev/md0: Access Denied


    root@BMNAS:~# sudo mdadm --examine --scan --sonfig=/etc/mdadm/mdadm.conf


    root@BMNAS:~# sudo mdadm --examine --scan --config=/etc/mdadm/mdadm.conf >> /etc/mdadm/mdadm.conf


    root@BMNAS:~# sudo mdadm -A /dev/md0


    root@BMNAS:~# /dev/md0 /mnt/md0 ext4 auto,users,user_xattr 0 2


    -bash: /dev/md0: Access Denied


    root@BMNAS:~# cat /etc/fstab


    # /etc/fstab: static file system information.


    #


    # Use 'blkid' to print the universally unique identifier for a


    # device; this may be used with UUID= as a more robust way to name devices


    # that works even if disks are added and removed. See fstab(5).


    #


    # <file system> <mount point> <type> <options> <dump> <pass>


    # / was on /dev/sdh1 during installation


    UUID=82405458-e9c5-4cf9-937b-9d596b118946 / ext4 errors=remount-ro 0 1


    # swap was on /dev/sdh5 during installation


    UUID=641c3788-8d90-4b07-8c28-2ec980384239 none swap sw 0 0


    /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0


    /dev/sdh1 /media/usb0 auto rw,user,noauto 0 0


    /dev/sdh2 /media/usb1 auto rw,user,noauto 0 0


    /dev/sdh5 /media/usb2 auto rw,user,noauto 0 0


    # >>> [openmediavault]


    # <<< [openmediavault]


    root@BMNAS:~# mount /dev/md0


    mount: /dev/md0 already mounted or /mnt/md0 busy


    mount: according to mtab, /dev/md0 is already mounted on /mnt/md0


    root@BMNAS:~# dd if=/dev/zero of=/dev/md0 bs=512 count=10000


    10000+0 records in


    10000+0 records out


    5120000 bytes (5,1 MB) copied, 0,239726 s, 21,4 MB/s


    root@BMNAS:~# mkfs.ext4 /dev/md0


    mke2fs 1.42.5 (29-Jul-2012)


    /dev/md0 bağlandı; burada bir dosya sistemi yapılmayacak!


    root@BMNAS:~# umount /dev/md0


    root@BMNAS:~# dd if=/dev/zero of=/dev/md0 bs=512 count=10000


    10000+0 records in


    10000+0 records out


    5120000 bytes (5,1 MB) copied, 0,270666 s, 18,9 MB/s


    root@BMNAS:~# mkfs.ext4 /dev/md0


    mke2fs 1.42.5 (29-Jul-2012)


    Dosya sistemi ismi =


    OS type: Linux


    Blok boyu = 4096 (günlük kaydı = 2)


    Adımlama boyu = 4096 (günlük kaydı = 2)


    Stride=128 blocks, Stripe width=256 blocks


    122085376 inodes, 488315648 blocks


    24415782 blocks (5.00%) reserved for the super user


    İlk veri bloğu = 0


    Azami dosyasistemi bloğu sayısı = 0


    14903 blok grubu


    Grup başına 32768 blok ve 32768 sekme


    grup başına 8192 düğüm


    Süperblokların bulunduğu bloklar:


    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,


    4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,


    102400000, 214990848


    Allocating group tables: bitti


    Düğüm tabloları yazılıyor: bitti


    Creating journal (32768 blocks): tamam


    Süperblokların ve dosya sisteminin hesap bilgileri yazılıyor: bitti


    root@BMNAS:~# mount /dev/md0 /mnt/md0



    After all these the mount button is still disabled. Also reference is mentioned as 'No'.

  • Yes, I'm resurrecting this thread. For good reason.
    I need to blow up ryecoaaron's ego because the man is a god. For 2 weeks I've struggled with rebuilding my 12 drive OMV array, and nearly every question I've run into, ryecoaaron has been the one with the answers in these forms. Just amazes me how well someone can understand this entire system.
    Most recently was an issue with getting my newly minted 5 drive Raid 5 array's filesystem to show as mounted in OMV. I wiped and started from scratch, just to arrive at the same conclusion again. Ran FSCK a dozen times to no avail.
    Ryecoaaron to the rescue. Just put an end to my hair-pulling. Finally.
    Thank you!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!