EXT4 : "Remounting filesystem read-only" every 2-3 days

  • Hello!

    I'm running OMV 2.2.1 on an Odroid XU4. The system is installed on the SDCARD, and I use an external hard-drive (USB2, 500GO) as storage. The system is idle most of the time, I generally use it to listen to music or watch movies in the evening.
    It runs perfectly for 4-5 weeks, except that I notice that, since 1-2 weeks, the storage filesystem is remounted in read-only mode every 2 days.

    It happened today, here is the relevant output from dmesg:

    [522943.556672] [c1] EXT4-fs error (device sda1): __ext4_journal_start_sb:62: Detected aborted journal
    [522943.564383] [c1] EXT4-fs (sda1): Remounting filesystem read-only

    In order to bring the filesystem back in write mode, I need to unmount it, run fsck.ext4. Then, when it is remounted, it is accessible in write mode... until the next time it is remounted in readonly mode...

    I know that there are a lot of chances that my disk is dying, but... how can I diagnose it?
    After the fsck, the hard drive works correctly, I can write big files at good speeds and they do not seem to be corrupted.
    Is there any other reason for this kind of errors?


    • Official Post

    It might be an unsupported sleep mode of the usb-to-sata controller. Not sure what could fix that though other than trying a different usb-to-sata dock.

    omv 7.0-32 sandworm | 64 bit | 6.5 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.7 | compose 7.0.8 | cputemp 7.0 | mergerfs 7.0.2

    omv-extras.org plugins source code and issue tracker - github

    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • ryecoaaron, you might be right... I'm under the impression that this happen when the drive is woken up by a write request. For example, I experienced this when I wanted to download a file with the 'downloader' function.
    It doesn't seem to happen when I just want to read files from the disk.

    Should I try different settings in "physical drive" from the administration panel (Advanced Power Management, automatic acoustic management)?
    There are several choices. For now, they are disabled, only the spin-down delay is set to 10 minutes.

    The external hard drive is this one from lacie : https://www.overclockers.co.uk…hard-drive-bg-022-lc.html

  • I've tried setting various values in the options of the physical drive (power management) without any luck : I experience random FS corruption. It seems to happen when the drive needs to restart from sleep mode.

    Previously, I used this same hard drive on my router with OpenWRT. At that time, it was formatted in FAT32, but I've never observed any corruption (but I don't know if FAT32 is smart enough to detect them).

    Is there any solution to this issue?

  • Hi, Do yo solve the problem? I have the same issue. After a few time, probably hours the fs of the USB disk is remonted in read-only mode. I use the rpi2 for download station.

  • Unfortunately, no...
    I'm still using it, but I regularly have to fsck the filesystem. I didn't see any corruption, but I don't use it for sensible data.
    I tried many things, parameters, commands,... with no luck.
    As ryecoaaron said, it might be an unsupported sleep mode, bug in the driver, in the USB adapter,...

    I plan on buying bigger hard drive, but I don't know if the issue will still be there or not...

    My conclusion : use native Sata... USB has its limitations...

  • Many thanks,

    I'm investigating now about ntp issue, I think the system remount the fs in read-only due to problem with the time.

  • I'm on 3.0.96 version and use pi3 with OMV. Still have exactly the same issue as JF002 has described

    If you use exactly the same setup (unreliable USB storage powered by an SBC) then most probably you run into the same issue called 'undervoltage'.

    Since you're using 3.0.96 you can simply open a shell and call

    sudo raspimon

    (stop with [ctrl]-[c] after a minute). To interpret the results: New approach for Raspberry Pi OMV images

  • Thank you for your information!
    I've red your topic on raspimon and did the test myself with some load (torrents+film vis smb). As far as I can understand I get normal results. I use official raspberry pi power supply which claim up to 2.5A

    I, also, use Y-shaped cable to my hard drive enclosure and power it power it from two USB ports at the same time. I'm going to experiment with additional power adapter for a hard drive.

  • As far as I can understand I get normal results

    At least raspimon is not reporting input voltage dropping below 4.65V. What's imporant is what's available at the disk (this is always lower than the input voltage) and many disk brands start to show problems as soon as their voltage drops below 4.75V (this is the minimum allowed by USB specs anyway). So it's perfectly normal that RPi shows no signs of undervoltage (4.65V INPUT) while at the same time a connected disk suffers from this (since VBUS OUTPUT voltage drops below 4.75V).

    The power circuitry on those Raspberry Pis is crap (read comments over there especially from lvrp16), the decision to use Micro USB for DC-IN as well and if you decide to let your RPi power a connected disk you're usually simply asking for troubles while not even being aware of the whole problem (Ohm's law) since the RPi foundation decided to masquerade the problem instead of fixing it.

    Y-cables don't help with voltage drops when connected to the same device (so useless here since all USB ports of a RPi share the same current limitation and the problem is not related to current but voltage drop under load) and it's strongly recommended to NEVER EVER use Y-cables with two different power sources since you can fry your device easily. These things are forbidden by USB specs for a reason.

  • HI,
    I'm on 3.0.96 version and use pi3 with OMV. Still have exactly the same issue as JF002 has described. Couldn't find the solution either.

    In my case, the external hard-drive died before I could find a solution for this issue. It was old, it was small, it was slow... I replaced it with 2*4TB on USB3, and they work very well.
    I don't think I had power issue, as the drive was self-powered. But I could imagine that a diyng drive could corrupt the filesystem during its agony...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!