What's wrong with these Samba settings?

  • Hi guys,


    I know - another thread concerning Samba and permissions... X/


    I have a shared folder for two users ("Ines" and "Rico") where both should be able to write, read and delete files. Unfortunately that doesn't work as intended: "Ines" can't delete "Rico's" files and vice versa.



    The settings using the GUI are as shown in picture 1 but in my opinion that doesn't correspond to the rights I see in CLI (picture 2).


    I read several days several manuals regarding Unix rights and permissions etc., I don't understand it: Why don't my users have the right to write even if they are allowed to according the GUI settings (as I understand it)??


    I'm so confused and don't find my mistake?! Can anybody help me please?

    Images

    Usul 5.5.23-1

    running in Proxmox on

    Mobo: Asus H87I-Plus (C2) Socket 1150
    RAM: 8GB (2x 4096MB) Kingston ValueRAM DDR3-1600 DIMM CL11 Single
    CPU: Intel Pentium G3220 2x 3.00GHz So.1150 BOX
    PS: 300 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Bronze
    OS: 64GB SanDisk Solid State Disk (SDSSDP-064G-G25)
    Data: 2x 4000GB WD Red WD40EFRX
    Case: Chenbro SR30169 mini ITX (4 bay) - but removed that crappy backplane :)

  • In the permissions column, the first three columns are for the owner and the next three are for the group. Rico's files are owned by user Rico and group users. The owner has r/w/execute privileges but the group only has read/execute privileges. Since Ines is in the group users but not the owner, that user cannot delete or modify Rico's files. You need to reset the permissions on the files and maybe even change the default creation privileges.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yeah, I know WHAT's wrong, I just don't understand WHY it is like this. In my opinion all settings are correctly set in the GUI but that doesn't match the result I see when checking it in CLI.



    I know I can do a CHMOD on these files/folders but what happens the next time?



    How do I permantly change these permissions?

    Usul 5.5.23-1

    running in Proxmox on

    Mobo: Asus H87I-Plus (C2) Socket 1150
    RAM: 8GB (2x 4096MB) Kingston ValueRAM DDR3-1600 DIMM CL11 Single
    CPU: Intel Pentium G3220 2x 3.00GHz So.1150 BOX
    PS: 300 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Bronze
    OS: 64GB SanDisk Solid State Disk (SDSSDP-064G-G25)
    Data: 2x 4000GB WD Red WD40EFRX
    Case: Chenbro SR30169 mini ITX (4 bay) - but removed that crappy backplane :)

  • The default permissions for samba are:
    create mask = 0755
    force create mode = 0644
    directory mask = 0755
    force directory mode = 0755


    If you don't like these (which you don't), you need to change them. You can override the setting in extra options by adding the lines above with the permissions you want (0775 for dirs and 0664 for files from the sound of it). You will have to fix the existing files though. omv-extras (on OMV 2.x) installs a reset-permissions tab that can fix the existing files for you.

    omv 5.6.6 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Ok, I see. So no "real" mistake happened somewhere, it's more an unclear description in the settings I guess.


    @subzero79: I know that switch but since I wasn't sure what side effects it's use might cause I left it alone


    Thanks for your help guys! I'm sure I can solve my problem now since you showed me where to look at!

    Usul 5.5.23-1

    running in Proxmox on

    Mobo: Asus H87I-Plus (C2) Socket 1150
    RAM: 8GB (2x 4096MB) Kingston ValueRAM DDR3-1600 DIMM CL11 Single
    CPU: Intel Pentium G3220 2x 3.00GHz So.1150 BOX
    PS: 300 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Bronze
    OS: 64GB SanDisk Solid State Disk (SDSSDP-064G-G25)
    Data: 2x 4000GB WD Red WD40EFRX
    Case: Chenbro SR30169 mini ITX (4 bay) - but removed that crappy backplane :)

  • So I tested "Resetting Permissions" and it worked in that way that all users can now delete everything.
    What I don't like with this solution: Everything is now owned by root (not sure if this might cause any problems later...). So I guess I better CHOWN everything afterwards.


    I have checked some older folders+files: I can see my permissions were OK until about April 2016. At one point around then something must have mixed up these permissions :(


    Strange thing: I didn't change or install anything - at least on purpose - since I was absolutely satisfied with my OMV.

    Usul 5.5.23-1

    running in Proxmox on

    Mobo: Asus H87I-Plus (C2) Socket 1150
    RAM: 8GB (2x 4096MB) Kingston ValueRAM DDR3-1600 DIMM CL11 Single
    CPU: Intel Pentium G3220 2x 3.00GHz So.1150 BOX
    PS: 300 Watt be quiet! System Power 7 Bulk Non-Modular 80+ Bronze
    OS: 64GB SanDisk Solid State Disk (SDSSDP-064G-G25)
    Data: 2x 4000GB WD Red WD40EFRX
    Case: Chenbro SR30169 mini ITX (4 bay) - but removed that crappy backplane :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!