Cannot browse external smb folder from ftp

  • Hi all,
    I have this scenario in fstab:

    #this is the remote samba share
    // /mnt/ready_share cifs defaults,uid=pi,gid=pi,user=guest,password=guest,rw 0 0

    #this is the usb attached drive
    UUID=d67cade7-889e-47ba-9c68-6667ddd03259 /media/d67cade7-889e-47ba-9c68-6667ddd03259 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,,jqfmt=vfsv0,acl 0 2

    I have 2 shared folder named "ready_share" and "screenplayhd"
    When I log in into the ftp using filezilla I see both (as shown in attached picture) but when I try to access ready_share I have this log and I cannot enter this folder:

    Status: Starting download of /ready_share
    Command: CWD /
    Response: 250 CWD command successful
    Command: TYPE A
    Response: 200 Type set to A
    Command: PASV
    Response: 227 Entering Passive Mode (192,168,0,11,244,220).
    Command: RETR ready_share
    Response: 550 ready_share: No such file or directory
    Error: Critical file transfer error

  • pi@raspberrypi ~ $ ls -la /mnt/ready_share
    total 483036
    drwxrwxrwx 1 pi pi 0 Aug 10 21:16 .
    drwxr-xr-x 3 root root 4096 Jul 19 08:38 ..
    drwxrwxrwx 1 pi pi 0 Aug 10 21:08 Backup
    -rwxrwxrwx 1 pi pi 4096 Apr 19 19:42 ._.DS_Store
    -rwxrwxrwx 1 pi pi 10244 Sep 9 00:14 .DS_Store
    drwxrwxrwx 1 pi pi 0 Aug 10 21:30 Film
    drwxrwxrwx 1 pi pi 0 Mar 23 17:11 Giochi_img
    drwxrwxrwx 1 pi pi 0 Aug 12 22:54 rsync_backup
    drwxrwxrwx 1 pi pi 0 May 10 22:16 Software
    drwxrwxrwx 1 pi pi 0 Mar 22 22:48 System Volume Information
    -rwxrwxrwx 1 pi pi 494592000 Aug 10 21:16 test.tmp
    drwxrwxrwx 1 pi pi 0 Apr 15 10:05 tmp
    drwxrwxrwx 1 pi pi 0 Jul 13 01:05 wordpress

    The path is right, I mounted the remote samba in this location.
    Could be a problem?

  • mcgyver83 wrote:

    Could be a problem?

    Maybe i am just trying to figure out how did you manage to put this folder "/mnt/ready_share" as an FTP share using the omv webUI

    Because for me you clearly added that fstab entry, but is pointing to a location omv cannot access or share.

  • mmm so this is the issue...I have a symlink from /dev/mmcblk0p3/ready_share to /mnt/ready_share ..
    I'll remove this.

    I created a new folder in /media/ready_share, changed the entry in fstab but where I use the omv webui to create a new shared folder I can select only the usb attached drive or mmcblk0p3 as Volume; how can I manage via gui this remote samba folder?
    I tried using remote share but when I assign it to a volume (as example /dev/mmcblk0p3) when I write files in the remote folder it fills the free space of the volume like described there remote samba share

  • Ok, change the cifs fstab entry to this (make sure this is out of the omv tags in fstab)

    // /media/d67cade7-889e-47ba-9c68-6667ddd03259/ready_share cifs defaults,uid=pi,gid=pi,user=guest,password=guest,rw 0 0

    Make sure the folder exists

    mkdir /media/d67cade7-889e-47ba-9c68-6667ddd03259/ready_share

    reboot, then create a shared folder with this /media/d67cade7-889e-47ba-9c68-6667ddd03259/ready_share

    Then add it to FTP

  • ok, many thanks, I will try.
    I tried instead of mounting the external smb in the USB harddrive, mounting it in the other /media/f6xxxxxxxc-xxx-xxx/ that is the volume named mmcblk0p3 in omv.
    mmcblk0p3 has 3,2GB of free space, external smb has 960GB of free space.
    When I did it, writing in the smb mounting point caused the fulfill of the mmcblk0p3 volume, despite of I was writing the external smb mounting point.
    This was explained in the topic I put in the previous message; at the end was figured out was that there is a bug.

    Let try with your suggestion!!!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!