Thecus NAS running OMV 3.0 -- Fault during field system build

  • Hi All,


    Best to start of by admitting Linux is new for me, i have been seeing about with this for a week now, reading a lot on this forum. OMV install went well, disk raid was deleted by me an re-created as Raid 1. Tried to initiate the file system and that is when things go wrong, i followed the progress on drive no.3 which is a stand alone, at around 1/3 of the progress there was a failure and the NAS rebooted.
    Tried it several times on the Raid 1 disks as well as the stand alone but nothing helps, and that is where my very basic Linux knowledge let's me down. Would be great if someone has a few things i can try over the next few days.content1477573404.txt

  • First thing I would do is install omv-extras and install the backports kernel using the button in om-extras. This may give better hardware support.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thank you for you super fast reply


    OK, backport kernel is installed, can i just retry the file system build or are there any steps to follow before?

  • I would just retry the file system build after rebooting of course.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The two drives that comprise Raid 1 haven successfully build the file system and are now syncing. I had tried to do the 3rd HDD as well but that still failed so i will wait until the sync operation has finished.


    Thank you for your assistance

  • Are you sure the third drive is not failing?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I sure hope not, it is visible in Physical disks and i can select it when i was building the other raid , not sure if that means it is still in good condition. The fault it showed before was similar to what the Raid1 file system build did and that one eventually cleared so....

  • Look in the SMART tab for more info.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Sorry, messed up. Just found i hadn't actually installed the backports kernel, just tried to correct that mistake and get the below error.



    Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf omvextras installbackports': Install backports 4.7 kernel and headersReading package lists...Building dependency tree...Reading state information...' in /usr/share/openmediavault/engined/rpc/omvextrasorg.inc:241Stack trace:#0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMVRpcServiceOmvExtras->{closure}('/tmp/bgstatuspq...', '/tmp/bgoutputRb...')#1 /usr/share/openmediavault/engined/rpc/omvextrasorg.inc(244): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#2 [internal function]: OMVRpcServiceOmvExtras->doCommand(Array, Array)#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('doCommand', Array, Array)#5 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('OmvExtras', 'doCommand', Array, Array, 1)#6 {main}

  • What is the output from: omv-mkconf omvextras installbackports

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You typed omv-mkconfig instead of omv-mkconf

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • :rolleyes:


    install backports 4.7 kernel and headers
    Reading package lists...Done
    Building dependency tree
    Reading state information...Done
    E: Unable to locate package linux-image-4.7.0-0.bpo.1-586
    E: Couldn't find any package by regex 'linux-image-4.7.0-0.bpo.1-586'
    E: Unable to locate package linux headers-4.7.0-0.bpo.1-586
    E: Couldn't find any package by regex 'linux-headers-4.7.0-0.bpo.1-586'

  • Do you have the backports repo enabled in the repo list of omv-extras? If there is no backports repo, then you need to update omv-extras.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • What is the output of: apt-cache policy linux-image*

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • that is quite an output file, have to figure out how to do this from the GUI because i can't copy from the console attached to my NAS

  • Is linux-image-4.7 in there?

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!