OpenVPN Client using PIA - DNS issues when VPN is connected

  • I'm trying to get OpenVPN to connect to PIA via the client. I need it to connect at startup as well. I got this working on my Raspberry Pi OMV install without any problems immediately. After testing there, I decided to move to my production NAS and this is giving me DNS issues.

    Here's the directions that worked immediately on the Pi install. I replicated them on prod.…envpn-openmediavault.html

    I also added these lines to the OVPN/CONF files on prod in an attempt to correct the DNS issue.…th-openvpn-on-ubuntu-box/

    So basically, when I run OpenVPN with the OVPN file, it connects fine but then DNS fails immediately.

    I did copy the OVPN to a CONF and point to it in the /etc/default/openvpn file to autostart by name. That's another issue, but I want to focus on the DNS issue first.

  • Routing tables if it helps...

  • You can find the solution using google, look at the resolv.conf symbolic link log. Dns is not able to be setup dynamically.

    dpkg-reconfigure resolvconf

    If it doesn't work try OpenVPN irc channel, you'll find better support there.

    This totally did it! Thank you! I did see a reference to this, but I didn't think it applied.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!