Issues Resolving Hostnames After Adding Interface

  • Hey guys,


    to test out a few options to report back to this thread about my built, I wanted to get the USB-Gigabit adapter for my RPi3 working. I kinda did, but I must have messed up something along the way.


    As OMV overwrites /etc/network/interfaces if you edit anything in Network>Interfaces, I added the adapter as eth01 by hand after setting WLAN up through the GUI. I can reach the Web GUI through all three interfaces, but I can't connect to anything outside of my network.


    After getting errors trying to install plugins I used omv-aptclean as root and got tons of "Something wicked happened resolving 'archive.raspberrypi.org:http' (-5 - No address associated with hostname)" and "W: Failed to fetch https://openmediavault.github.…ain/binary-armhf/Packages Could not resolve host: openmediavault.github.io", so I figure I made a mistake when editing /etc/network/interfaces.


    Here's the file:

    ifconfig gives me:

    What did I mess up here?


    Thanks in advance,
    V

  • Go back and edit the interface(s) via the GUI and specify DNS server(s)

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Managed to add DNS servers throught the command line and it worked! Thanks a lot!

  • Have you tried



    omv-firstaid


    In CLI to repair your eth1?


    BTW you mentioned above you named your USB-Gigabit interface eth01, afaik it should be named eth1 instead.

    OMV 3.0 with bpo Kernel running on:
    Board: ASRock Q1900-ITX
    RAM: 4GB DDR3-1066 Kingston ValueRAM
    Case: Coolermaster Elite 120 Advanced
    HDD: 1x 40GB 2.5" Samsung for System and 1x 3TB 3.5" Seagate ST3000DM001 + 1x3TB 3.5" Seagate SV35.5

  • Thanks, yeah that was a typo, it was correct in the file. I edited it in CLI and added DNS servers for each interface and now it works.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!