A start job is running for ... <LUKS encrypted disk>

  • Hi everybody,


    on boot, my NAS waits for "A start job is running for <UUID of LUKS encrypted disk>" to timeout, which adds 1:30 min to the boot time. According to this thread I added the option "noauto" to the disk in /etc/fstab. This solves the problem as the system does not wait 90 seconds on boot, which makes booting pretty fast. However, after unlocking the disk via the encryption plugin in the webUI, it now is not mounted automatically any more.



    How can I prevent the 90 seconds delay on boot and still have the disk auto mounted after I unlock it?


    Best,
    Aiakos

  • The encrypted device is an internal HDD and registered within omv. Unless I add the "noauto" option manually from fstab, the disk gets automatically mounted once I unlock it. My question is:
    - Is there another option to avoid "A start job is running ..." on system boot without adding "noauto"?
    - or how can I ensure auto mounting of the disk even though the noauto option is set in fstab?

  • You can set a shorter timeout but that's also an extra fstab option. x-systemd.device-timeout=2


    I am a little bit confused here. You said st the beginning, mounting wasn't happening after unlock, now you said it works. I would guess the plugin doesn't care about noauto it looks for a referenced fs when it unlocks.

  • Sorry, maybe I did not explain it very well. What I meant was that the disk gets auto mounted after I unlock it, but the systems waits for the timeout on boot. I can avoid this timeout by adding "noauto" to fstab, but then the disk does not get mounted automatically any more, after I unlock it. My question was how I can have both auto mounting and no timeout on boot. ;-)


    Your suggestion regarding reducing the timeout to two 2 seconds seems to work. Thus, I consider the problem to be solved. Thank you!

  • Same here. I have one hdd with LUKS2. And there was also too slow start with message "A start job is running"... So I add x-systemd.device-timeout=4ms to fstab:


    defaults,nofail,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl,x-systemd.device-timeout=4ms


    Another issue found when looking for solution: in crypttab there should be record about this disk, but its empty.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!