Linux-Mint : poor samba performance

  • Hi,


    I've got very poor samba performance (r/w) from my LinuxMint Laptop (dual-boot) to my OMV-server.


    Speed (r/w) with LinuxMint:
    SMB: 3 MB/s (mounted with nemo)
    SSH: 40 MB/s


    Speed (r/w) with Win10:
    SMB: 35 MB/s


    Client:
    Dual-boot laptop with WiFi AC (connected above 600 mb/s).
    Win10
    LinuxMint 18.3 cinnamon


    Server:
    HP-N54L (connected 1gb/s, wired)
    OMV 4.0.14-1


    So, obvisously there is a problem with the SMB Mint-Client and the server.


    Which experience have other users with minit or ubuntu client?
    Any ideas to get LinuxMint performing like expected? ?(

  • Are you sure the wireless is connecting at the same speed on Linux Mint? My xps13 doesn't on Ubuntu 18. Samba speed is just fine with a usb network adapter.

    omv 6.0.34-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Are you sure the wireless is connecting at the same speed on Linux Mint? My xps13 doesn't on Ubuntu 18. Samba speed is just fine with a usb network adapter.

    Yes it does. Checked it with iwconfig.
    I tested also with an usb adapter. Of cource better, but the ratio between SMB and SSH was the same.
    SMB was also poor.

  • Yes it does. Checked it with iwconfig.
    I tested also with an usb adapter. Of cource better, but the ratio between SMB and SSH was the same.
    SMB was also poor.

    Do you have any samba optimizations in extra options on the samba settings tab?

    omv 6.0.34-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Try looking at the samba tuning threads.

    omv 6.0.34-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Also I would try not mount with nemo. Test using the mount smb command manually.

    Good point.
    I mounted manually with an entry in fstab:

    Code
    //server.lan/homes/user /home/user/server cifs rw,user,noauto 0 0

    and

    Code
    user@mint ~ $ mount /home/user/server

    in the terminal.


    Now things go crazy:
    Up- and download speeds rise up to 40 MBytes/s. That quite OK and expected. :thumbsup:
    When I replace a file on the client-side, the speed drops down to 20 MByte/s, which is acceptable.




    But if I replace a file on the server-side, the speed drops down to 300 kByte/s. ;(
    Tried to force SMBv2 on the client side, but that made no difference.




    I'm running out of ideas...

  • I'm running out of ideas...

    Did you add any of the tuning parameters from the tuning threads?

    omv 6.0.34-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Did you add any of the tuning parameters from the tuning threads?

    ...too stupid, to find them.
    You have a link for me?


    But in the meantime I investigated a little bit more and found out that
    cache=loose
    on the client-side enhances the perfomance dramatically:
    File replacement on the server-side is now 20 MByte/s (coming from 300kByte/s).
    But this also reduced download speeds to 20 MByte/s.


    Here my actual mount:


    Code
    //server.lan/homes/user on /home/user/server type cifs (rw,nosuid,nodev,relatime,vers=2.0,sec=ntlmssp,cache=loose,username=xxxx,domain=,uid=1000,forceuid,gid=1000,forcegid,addr=192.168.1.8,file_mode=0755,dir_mode=0755,nounix,serverino,mapposix,rsize=65536,wsize=65536,echo_interval=60,actimeo=1)



    I'm not trying to get the last 10%.
    I'm just trying to get an acceptable performance.
    So I ask myself, why are the default settings so "unusable" in LinuxMint.

  • You have a link for me?

    Tunning Samba for more speed
    Tuning Samba for more speed 2


    When you get an error posting, please don't keep trying. That is the spam filter and your post will be approved shortly.

    omv 6.0.34-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The tuning tips did not change performance dramatically.


    For me, these steps brought reasonable speed:


    Mount manually. Do not use nemo.
    Use parameters "vers=3.0" and "cache=loose" in fstab.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!