Cannot create socket to [localhost]:2812 -- Connection refused

  • Hallo forum

    I need your help!!

    i just reinstalled / fresh omv4 and updated to : from the web gui

    But when i run "systemctl status monit" i get this error:
    Cannot create socket to [localhost]:2812 -- Connection refused

    and i cant see omv4 is listining to to 2812 when i run "netstat -pln"

    please help!!!

    i ran "systemctl stop rrdcached.service"
    and started it again "systemctl start rrdcached.service"

    and now it seems its working even after reboot?

    a bug?

  • I read on github "delay is controlled by the first line in /etc/monit/monitrc ;"
    set daemon 30 with start delay 5

  • Ich habe auch das selbe Problem. Nach einer Neuinstallation und jetzt Grade bei Upgrade auf 4.1.13-1 wird mir der Fehler angezeigt.

    Und eine Frage noch: Ich kann nicht mehr per Host auf die OMV GUI zugreifen (in meinem Fall http://myhomeserver/) nur per IP funktioniert


  • Cannot create socket to [localhost]:2812 -- Connection refused

    Same problem here running OMV 4.1.22, monit was unable to connect to localhost at port 2812. The issue appeared when changing the configuration to delete a shared folder, I was unable to apply the changes in configuration.

    I had very same issue with 2812 port, but had not opened this port in my firewall. Once you open it, works fine.

    Confirmed, opening the port on my router worked for me as well. It's an ugly workaround but solved the problem for now.

    EDIT: UPDATE 27 Apr 2019:
    unfortunately it didn't work after all. Syslog still complains:
    monit[4754]: Cannot create socket to [localhost]:2812 -- Connection refused

    Edited 2 times, last by mdr ().

  • Good evening everyone,
    by following the previous responses I executed $ nano /etc/monit/monitrc
    and found that set daemon 30 with start delay 5 was present.
    By changing the values and

    doing a $ monit status the service was still hitting wall.
    My solution was $ systemctl restart monit.service with a minute's delay or so $ monit status to check if the service was up and running appropriately.
    Apparently it needs to be set manually, or properly initialised. The latter is not yet my forte, the first was a small wiki search / documentation search.
    Me being a novice user, I looked at the site and it had a very nice presentation which said that the monit is supposed to be a daemonised service, leading me to contemplate whether the daemon had enough time to initialise.

    Have a nice day, or night... :)

  • Ok, now I'm here. I have been having lots of trouble with my OMV4 install, but strangely, it's sort of booting I don't want to touch anything. But I cannot acquire a network link, due to this very same error. I tried changing the monit config, but still getting the same error.

    Do I need to open up this port to the outside world? I don't like that idea, but why is this error occurring, can anyone please help?

  • I have an address now. However, still can't log into the box with the admin account (still dropping back to the login prompt):

    Would you please be more specific in describing what you are trying to accomplish, through which method and that this issue is? I'm no sysadmin or developer but a clear description of the issue is a starting point for help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!