Plex Docker Container is routed through OpenVPN from Transmission-OpenVPN Container

  • Hello all, I'm surprised no one has had this issue before but, when running both Plex and TransmissionOpenVPN on docker, Plex is not accessible via remote access but works fine on the local network. It is reading my public vpn address. I don't know how the two containers are communicating, but they are both set under the Host network mode. Plex's remote access starts working immediately when I stop the TransmissionOpenVPN container.

    I have my ports forwarded, as well as additional ports forwarded through the VPN, but Plex simply won't comply for some reason.

    How can I separate the two networks entirely?

  • I figured it out.

    You just have to set the TransmissionOpenVPN container on bridged mode. I use my server's IP for the Host IP, select 9091 for the host port, 9091/tcp for the exposed port, and add.

    Problem solved.

  • Thanks for this, its a problem I have been struggling with for a while. The problem now is I can't open the webui now.

    I have tried following the LOCAL_NETWORK instructions on the docker guide to the best of my abilities, but still can't get it to work.

  • For those still having issues with this I was able to solve by doing the following:

    Leave Plex in host mode.

    Set Transmission-OpenVPN container to bridge mode.
    Host = your server IP.
    Port = 9091.

    If you make these changes and can no longer access the Transmission web gui - modify your docker container and verify that the LOCAL_NETWORK environmental variable is set to the correct IP address range (i.e. for your network.

    Transmissions web gui should now be available.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!