Docker permissions Noexec

  • I am trying to install ovenvpn-as docker. I am running into a permission error. I would like to change the permissions from noexec to exec.


    I can't find it here:

    Code
    /etc/default/openmediavault


    or here:
    Where did it go?


    Code
    /etc/openmediavault/config.xml

    Build, Learn, Create.


    How to Videos for OMV


    Post any questions to the forum, so others can benefit from your curiosity. :thumbsup:
    No private support.

  • nano /etc/fstab


    via command line. Replace noexec with exec



    Gesendet von iPhone mit Tapatalk

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • nano /etc/fstab


    via command line. Replace noexec with exec

    That will only work until the next reboot and then fstab will be re-written. The mntent entry needs to be changed in /etc/openmediavault/config.xml and the omv-mkconf fstab executed.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • That will only work until the next reboot and then fstab will be re-written. The mntent entry needs to be changed in /etc/openmediavault/config.xml and the omv-mkconf fstab executed.


    Are you sure? I always changed noexec to exec in fstab otherwise Plex (docker) refused to work properly and after restart Plex was working fine



    Gesendet von iPhone mit Tapatalk

    OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Xeon E3-1245 v6 Kaby Lake (4x3.70GHz), 16GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 30GB system, 4GB swap, sda5/rest - for work), 1x 10TB WD Red Pro, 1x 3TB WD Red (both basic setup) - Digibit R1 Sat-IP-Server with SatIP-Axe-Firmware


    OMV-Server-SW: Debian Buster with Proxmox kernel (always up-to-date), OMV v5 (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker with PlexMediaServer, TVHeadend, any many more


    BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2

  • Are you sure? I always changed noexec to exec in fstab otherwise Plex (docker) refused to work properly and after restart Plex was working fine

    I guess it depends on which plugins you have installed and if you are doing anything in the web interface. The reboot itself doesn't necessarily trigger it but changing things in plenty of other services (nfs, sftp, zfs, etc) does.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • im not a linux expert.
    so what needs to be done ?

    Second this attempting to get Plex transcoding working through docker and I'm still trying to figure out how to edit /etc/openmediavault/config.xml to exec

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!