Install OMV5 on Debian 10 (Buster) OMV 5.x (development)

  • Hallo,


    I tried the install on Buster Alpha3 and get the following error.


    The following packages have unmet dependencies:
    openmediavault : Depends: php-pam but it is not going to be installed
    Depends: salt-minion (>= 2018.3.3) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    I followed all the steps as per guide, got past the kering problem and got stuck on this error.


    How can I fix this?


    Thanks,


    Jim

  • You are not using the OMV package repo

    Myself and a couple others had the same problem. Is there another repo other than what is in your OMV 5 install guide?


    And speaking of that, you can't add a repo without it being trusted and install a package from it. So, adding the repo to install the keyring package won't work anymore. wget/dpkg is probably a better method unless you want to put trusted in the repo line (I don't). Or even do what I do with omv-extras and write an shell install script.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Myself and a couple others had the same problem. Is there another repo other than what is in your OMV 5 install guide?
    And speaking of that, you can't add a repo without it being trusted and install a package from it. So, adding the repo to install the keyring package won't work anymore. wget/dpkg is probably a better method unless you want to put trusted in the repo line (I don't). Or even do what I do with omv-extras and write an shell install script.


    I can't confirm that, the vagrant box is using exactly the same script as the guide in the forum.

  • I can't confirm that, the vagrant box is using exactly the same script as the guide in the forum.

    The vagrant Buster image must have extra packages and/or repos then. I'm quite familiar with installing OMV and it doesn't work with a base Buster install :)

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • apt-get update gives the following response on my system:


    Hit:1 http://security.debian.org/debian-security buster/updates InRelease
    Hit:2 http://ftp.ca.debian.org/debian buster InRelease
    Hit:3 http://packages.openmediavault.org/public usul InRelease
    Reading package lists... Done


    so it looks like it hits the right repositories.


    still the error persists:


    The following packages have unmet dependencies:
    openmediavault : Depends: php-pam but it is not going to be installed
    Depends: salt-minion (>= 2018.3.3) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    Any other suggestions?

  • the vagrant box is using exactly the same script as the guide in the forum.

    What version of python3-tornado is vagrant installing and from where? I think you should rebuild the salt-common package to use python3-tornado 5.1.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • can't confirm that, the vagrant box is using exactly the same script as the guide in the forum.

    I looked a little more into this. The vagrant image must be old and Buster has moved on. salt-common/salt-minion don't even compile from source because python3-tornado4 or python3-tornado << 5 don't exist in buster. So, I guess vagrant is the only way to test for now.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The Debian buster image for the vagrant box is used for OMV5 development. This is the fastest way to setup a dev system. So this is the current state for Debian 10 integration.


    OMV will never build external packages, so we have to wait for official SaltStack packages.

  • The Debian buster image for the vagrant box is used for OMV5 development. This is the fastest way to setup a dev system. So this is the current state for Debian 10 integration.

    I understand that but you are building on an old version. Maybe you should dist-upgrade that image in your script (I know it would be slower) to test against the current state of Buster? Personally, I don't want to use vagrant when developing/porting plugins. I like having running VMs on my VMware cluster. I know vagrant works with VMware but it is quite expensive.


    OMV will never build external packages, so we have to wait for official SaltStack packages.

    I just wanted something that works. So, I was trying to compile the Debian Sid source with the assumption that these might someday be in the Buster repo.

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • @votdev I know I am probably kicking a dead horse but I figured I would update the thread. Tthe vagrant image is from June which must still be using php 7.0. Current Buster is using php 7.3. I was able to build the salt packages and php-pam on up to date buster (here is anyone cares) and modify every reference in the openmediavault package to use php7.3 instead of php7.0 but the postinst script still fails. Frustrating since I finally have a little time to port plugins while on vacation but I can't get a working, updated OMV5 system :(

    omv 5.5.11 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.3.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Trying to test TimeMachine via SMB as requested and now struggling. To check for TimeMachine support running on Buster would be a requirement due to shipping with Samba 4.9? But OMV5 installation fails and I don't think testing OMV5 on Stretch would be sufficient unless I get Samba 4.8 or above running there.


    Am I missing something?

  • And


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!