Plex in Docker - Transcoder Problem - Write Permissions?

  • Hi Everyone!
    I finaly installed OMV4 and with this done, I want to use Docker for my Plugins.

    I really like the Videos of Techno Dad Life, so I followed his Tutorial. Plex works so far, I even can watch Videos in original Quality, but when a Video must be converted it doesn`t work.

    Conversion failed. The transcoder exited due to an error

    There are many guys in the web who have the same problem, but I couldn't find a solution for me.
    I think it could be a premission Problem, so I will tell you what kind of folders I have and what permissions they have.

    At first, my Docker looks like this:

    My Shared Folders look like this:


    ACL settings:

    Can someone help me with my problem?
    Thanks a lot!

  • I've been too early pleased - now there is an other error massage:

    “Conversion failed. A required codec could not be found or failed to install.”

    Which means:

  • Which means:

    From my understanding of Plex it's probably a permissions issue in relation to the transcode folder i.e. the PMS user does not have write permissions.

    Raid is not a backup! Would you go skydiving without a parachute?

    OMV 6x amd64 running on an HP N54L Microserver

  • That could be possible.
    I use a docker container for PLEX and Docker is absolutly new to me.
    In the Docker settings I set the PUID 1000 and PGID 100, thinking it is the admin user.

    Just for my Understanding: Is it correct, that I can put in the PUID and PGID of my Admin user in docker and then just have to give this user write permissions to the transcoding folder?

    And one more question: I created a new Folder for the transcoding, but as far as I know, there is a trancoding folder in the Library Folder of Plex.
    So I guess the standard Folder will be used if I don't change the settings?

  • You might as well ask me 'how long's a piece of string' :) I use Emby not Plex but the principle I believe is the same.

    The PUID for Admin is 998 I think, when I set up Emby initially I used Admin as the PUID and PGID, not a problem as initially it worked until I come to set up the Web GUI, no Emby user!! So back to OMV created an Emby user then gave them read/write permissions on the appropriate folders, which in my case I have a share called EmbyServer this stores the cache, metadata and transcoding-temp folders, problem solved. As my SMB shares for Emby are set to everyone I don't have to bother adding the Emby user to those.

    Raid is not a backup! Would you go skydiving without a parachute?

    OMV 6x amd64 running on an HP N54L Microserver

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!