Hard Drive wakes up frequently due to 'anacron jobs' log entry plus other log entries.....

  • Hello,
    I am really new to OpenMediaVault and have minimal experience in Linux. I have just installed OMV 4.x on an Odroid-HC2 unit. I have installed hard drive and everything is working fine. The drive goes to hibernation after 2 hours as specified and I can access the shared folders just fine. I have not installed any 'packages' and only service tha tis running is CIFS/SMB. But I am having 2 issues:

    1) The hard drive wakes up frequently from hibernation. It seems that hard drive wakes up every hour (however I am not certain). I have set the hibernation timer to 2 hours but the weird thing is when hard drive wakes up, it just goes back to hibernation within few minutes. I have identified following entry in the log which corresponds to the waking-up of the drive: "systemd[1]: started run anacron jobs".
    I have not scheduled any jobs and it is only bare-bone installation. How should I resolve 'anacron jobs' from waking up the drive.

    2) The other issues is that I am having multiple and repeating log error messages and I am worried that these frequent log messages would fill up the OS drive soon. I need little help to either disable or resolve these log error messages.

    Here is the repeating log error is: "[cron932]: authentication token is no longer valid new one required".

    How do I resolve these?


  • How do I resolve these?

    No idea what you're meaning with 'hibernation'. But to resolve the authentication token issue check OMV settings for ssh, permit root login, then login via ssh and when you're asked to assign a new password choose a secure one.

    If you use the official OMV image for HC2 there's nothing to fear wrt log writes since flashmemory plugin is enabled.

  • Thanks for your answer. By hibernation I meant 'Hard drive spin down' under power management settings. I believe hard drive spins-up frequently due to "systemd[1]: started run anacron jobs" process.

    Kindly, can you plz elaborate on your last line , specifically "wrt log writes since flashmemory plugin is enabled".

    Thanks again,

  • I have not installed any 'packages'

    You should install and enable the openmediavault "flashmemory" plugin. This reduces the write access to the sd card where OMV is installed. This is meant with "wrt log writes since flashmemory plugin is enabled".

    OMV 3.0.99 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

  • Alright I have fixed this error "[cron932]: authentication token is no longer valid new one required" by changing root log-in using SSH , thanks for the helpful tip :thumbsup:

    I have Odroid-HC2 and I have confirmed that I do have 'flashmemory plugin' installed and enabled by default so I do not have to worry about log files being written on SD card too frequently.

    Now back to my original question which was about the hard drives being spinning-up randomly. I'll try to be more clear this time. I have installed the hard drive and under 'Advance Power Management' settings, I have assigned 120 minutes as spin-down time. Now I have noticed that my hard drive spins-up frequently and some times spins-up two times within an hour. And after spinning-up the hard drive goes back to sleep mode within 5 minutes. This is strange because I have assigned 120 minutes as spin-down time so I would not expect drive to go to sleep in 5 minutes after spinning-up.

    So I started checking the logs as soon as the hard drives spin-up and I have found following entries on three separate occasions at the same moment when drive was awaken by OMV.

    First indecent

    May 8 12:05:01 Odroid CRON[5317]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
    May 8 12:09:01 Odroid CRON[5406]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
    May 8 12:09:05 Odroid systemd[1]: Starting Clean php session files...
    May 8 12:09:05 Odroid systemd[1]: Started Clean php session files.

    Second incident

    May 8 11:38:59 Odroid smartd[1083]: Device: /dev/disk/by-id/ata-ST32000542AS_5XW1TY63 [SAT], SMART Usage Attribute: 195 Hardware_ECC_Recovered changed from 40 to 39
    May 8 11:39:01 Odroid CRON[4577]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
    May 8 11:39:09 Odroid systemd[1]: Starting Clean php session files...
    May 8 11:39:09 Odroid systemd[1]: Started Clean php session files.

    Third incident

    May 8 09:25:01 Odroid CRON[28653]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)

    Can some please point me to right direction on how to resolve these instances which causes to drive to wake up?

    And why the drive would go back to in spin-down mode when I have assigned 120 minutes as spin down threshold?

  • And why the drive would go back to in spin-down mode when I have assigned 120 minutes as spin down threshold?

    Since USB storage sucks in general. On the HC2 the SATA disk is behind a JMS578 USB-to-SATA bridge for which firmware updates are available (no idea whether you still need to apply them but part of the firmware flashing process is also setting the spindown time). Wrt spinning the drive up again maybe that's related to SMART checks. I would search the forum for posts from @Adoby -- IIRC he came across these problems as well and got them resolved.

  • Thanks for the tips on upgrading USB-to-SATA bridge firmware, I shall check out those.

    I have enabled the SMART checks only when HD is not sleeping. There is an option in OMV for that.

    Do you have any opinion on the above posted log entries that appear right at the moment of Hard Drive spin-up? Do these log entries tell you any thing about the HD spin ups?

    Thanks for your time.

  • Please see this post about problems with the HC2 and spindown, OMV APM settings and firmware, and how it was resolved:

    My new NAS: Odroid HC2 and Seagate Ironwolf 12TB.

    Also try to turn off scheduled SMART checks. Or run them only a few times per day at the most. Don't assume that they only run when the HDD is spining. The USB-SATA bridge may make that har to detect for the OS. I only run SMART checks manually, when I check for OMV updates and so on. Perhaps once or twice per month.

    Be smart - be lazy. Clone your rootfs. This help is Grateful™.
    OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • Both of you @Adoby & @tkaiser are geniuses. I would never have figured out that spin time time of hard drive in Odroid-HC2 is controlled by firmware of JMS578 USB-to-SATA bridge. My issues seems to have been fixed at the moment. Here is the recap of the issues and solutions for a future reader.

    - The hard drive in Odroid-HC2 was waking up frequently, sometimes even twice an hour without anyone accessing the HD. I have disabled the SMART checks and also disabled all the options under 'Advance Power Management' settings' including Acoustic management and spin down settings. Now hard drive is not spinning-up, or at least not spinning-up for few hours when I was around the Odroid unit.

    - The second issue was that hard drive was going back to sleep (spin-down mode) within 3-5 minutes of waking up. And the spin-down time option under 'Advance Power Management' settings' did not affect this behavior at all. Even when I disabled the spin-down setting in WEB GUI of OMV, hard drive would still spin down in 3-5 minutes. The reason for this is that firmware in JMS578 USB-to-SATA bridge was controlling the HD spin-down time. As discovered by @Adoby, I had to flash the firmware of JMS578 in Odroid-HC with updated spin-down timing of my choice to make it work. I flashed the firmware with '-t 120' switch and now hard drive spins down after 120 minutes. incredible ......

    PS: There is new firmware version of JMS578 USB-to-SATA bridge. which is released in March 2019. This version seems to fix the TRIM command and add the support of ATA command set firmware link.

    Thanks again folks.... :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!