Raspberry Pi 4 -- Using OMV4 on RPi4 with wifi

  • Warning: This has not been verified to work other than briefly. File transfer speeds over wifi may be disappointing.


    OMV4 doesn't seem to include the wifi drivers for RPi4.


    I have figured out how to install them to allow a RPi4 OMV4 NAS to work over wifi. Well, not actually. I just read this thread and did it: RPI4 OMV WiFi


    The steps I took to activate wifi on the RPi4 running OMV4:


    The steps below assumes that you login as a normal user, that you have created, that is a member of users, ssh and sudo. Also that SSH is enabled.


    1. Login remotely to the RPi4 using SSH and download the .deb with the drivers from raspbian.org:


    wget https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree/firmware-brcm80211_20190114-1+rpt2_all.deb


    (If it doesn't work there may have been an update, adjust the filename accordingly.)


    2.Install the drivers:


    sudo apt install firmware-brcm80211_20190114-1+rpt2_all.deb


    (I ignored any errors and warnings. Could bite me later. I don't know.)


    3. Reboot the RPi4 and then login remotely, using SSH, to the RPi4 again.


    4. Run the utility armbian-config with sudo and configure wifi.


    (It doesn't seem to work to configure wifi in the OMV4 web GUI. There are errors and you have to revert.)


    5. Shut down the RPi4 and remove the ethernet cable.


    6. Start the RPi4 and it will now work on wifi. You can connect to the OMV web GUI by opening raspberrypi.local in a web browser.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

    Edited once, last by Adoby ().

  • I just followed the steps but struggeling with the second step:



    root@raspberrypi:~# sudo apt install firmware-brcm80211_20190114-1+rpt2_all.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package firmware-brcm80211_20190114-1+rpt2_all.deb
    E: Couldn't find any package by glob 'firmware-brcm80211_20190114-1+rpt2_all.deb'
    E: Couldn't find any package by regex 'firmware-brcm80211_20190114-1+rpt2_all.deb'



    what i needed to do is:


    1)
    wget https://archive.raspberrypi.or…1_20190114-1+rpt2_all.deb
    2)
    sudo dpkg -i firmware-brcm80211_20190114-1+rpt2_all.deb


    now its working...

  • The deb file must be in the folder you "are in". Otherwise you need to add a path. Also check speling.


    The deb file should be listed if you type ls.

    Be smart - be lazy. Clone your rootfs.
    OMV 5: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

  • was not working like that.





    root@raspberrypi:~# dir
    firmware-brcm80211_20190114-1+rpt2_all.deb


    root@raspberrypi:~# sudo apt install firmware-brcm80211_20190114-1+rpt2_all.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package firmware-brcm80211_20190114-1+rpt2_all.deb
    E: Couldn't find any package by glob 'firmware-brcm80211_20190114-1+rpt2_all.deb'
    E: Couldn't find any package by regex 'firmware-brcm80211_20190114-1+rpt2_all.deb'


    root@raspberrypi:~# ls
    firmware-brcm80211_20190114-1+rpt2_all.deb


    root@raspberrypi:~# sudo dpkg -i firmware-brcm80211_20190114-1+rpt2_all.deb
    (Reading database ... 53571 files and directories currently installed.)
    Preparing to unpack firmware-brcm80211_20190114-1+rpt2_all.deb ...
    Unpacking firmware-brcm80211 (1:20190114-1+rpt2) over (1:20190114-1+rpt2) ...
    Replaced by files in installed package armbian-firmware (5.46) ...
    Setting up firmware-brcm80211 (1:20190114-1+rpt2) ...
    root@raspberrypi:~#

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!