autoshutdown 5.0.1 error with TEMPPROCNAMES="-"

  • Hi, made a pretty nice setup with OMV 5 and everything is working after 2 days of trial and error.
    Proxmox Kernel seems to be must for ZFS (Backports hasn't recognized my SATA Controller) and for docker I had to remove the apparmor package
    (else all containers restarting continously).


    As stated, all working as in OMV 4, only the autoshutdown plugin does not allow to exclude process supervision as it was possible in version 4 with
    TEMPPROCNAMES="-".


    SYSLOG shows the following errors several times

    Code
    Oct 5 16:16:00 NAS systemd[1]: /lib/systemd/system/autoshutdown.service:11: PIDFile= references path below legacy directory /var/run/, updating /var/run/autoshutdown.pid ‚Üí /run/autoshutdown.pid; please update the unit file accordingly.

    and


    Code
    Oct 5 16:17:45 NAS autoshutdown.sh[35429]: /usr/sbin/autoshutdown.sh: line 741: TRUE: command not found

    The autoshutdown plugin itself is then running in FAKE mode without this option being set in the menu before.

    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

  • One empty line in expert settings before TEMPPROCNAMES="-" did the trick. Furthermore updated /lib/systemd/system/autoshutdown.service in line 12.


    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

  • I would say it is a bug in the autoshutdown plugin - or two. One is the PIDfile issue described in the first error message, the second is that one CR is missing in autoshutdown.conf file that can be bypassed with one empty line in the plugin gui expert settings.

    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

  • One empty line in expert settings before TEMPPROCNAMES="-" did the trick

    This is fixed in 5.0.2.


    Furthermore updated /lib/systemd/system/autoshutdown.service in line 12.

    I changed this in the plugin but I don't understand why it was causing an issue since /var/run is a symlink to /run.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Tried 5.0.2 and is working well! Thanks a bunch, ryecoaaron. No clue why the symlink is not working. At least Debian
    tells us how to fix.

    HP Microserver Gen8 - 16GB RAM - 1x Kingston 120 GB SSD - 4x 3TB WD Red / ZFS - OMV 5.2.x bare metal - Docker running Plex, TimeMachine - Synology DS214 with 2x 4TB WD Red for rsync backup

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!