OMV5 + ZFS: Unable to add mirrored vdev to pool

  • Fresh install of OMV5 with proxmox kernel (1) and openmediavault-zfs (2) from Trying to create a ZFS pool with four mirrored vdevs (2x12 TB + 2x12 TB + 2x8 TB + 2x8 TB).

    I'm able to create the pool with the first mirror vdev, but expanding the pool with second set of mirror drives fails. Error message: A mirror must contain at least 2 disks. Yes, I am selecting two drives when expanding the pool :-)

    Confusingly, zpool status seems to be OK?

    root@omv-nas:~# zpool status
    pool: zfs-tank
    state: ONLINE
    scan: none requested
    zfs-tank ONLINE 0 0 0
    mirror-0 ONLINE 0 0 0
    ata-ST12000NM0007-2A1101_ZJV310R4 ONLINE 0 0 0
    ata-ST12000NM0007-2A1101_ZJV3B4T7 ONLINE 0 0 0
    mirror-1 ONLINE 0 0 0
    ata-ST12000NM0007-2A1101_ZJV24C09 ONLINE 0 0 0
    ata-ST12000NM0007-2A1101_ZJV2LDGN ONLINE 0 0 0

    After the attempt to expand with a second set of drives, the pool is missing from the ZFS overview. Also, the message 'A mirror must contain at least 2 disks' immediately pops up when selecting ZFS.

    Should I expand the pool using CLI instead of GUI, or what am I doing wrong here?

    Thanks for any pointers in the right direction!

    (1) Proxmox kernel installed because the 5.2 kernel in backports is currently uninstallable: linux-image-amd64 depends on linux-image-5.2.0-0.bpo.3-amd64 which is missing from the backports repository.

    (2) openmediavault-zfs installation initially failed because zfs module wasn't ready when setting up zfsutils-linux. Fixed with modprobe zfs; apt install.

  • Your zpool status looks good. Did you try to reboot after expanding the pool? I would assume that after a reboot the pool is recognised again from OMV.

    I have created my stripped RAIDZ1 ZFS pool by CLI because some operations did not work properly with the ZFS plugin (I remember some issues in the past especially when expanding the pool). But the pool is working without any problems in OMV.

    If you have still problems with the expanded pool, I would destroy the pool and create the pool again by CLI, followed by a reboot. Then it should work.

    OMV 3.0.100 (Gray style)
    ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

    Edited 2 times, last by cabrio_leo ().

  • Thank you for responding!

    After rebooting, the pool is still missing from the ZFS overview. Also, the message 'A mirror must contain at least 2 disks' immediately pops up when selecting ZFS. zpool status still seems OK.

    Is the ZFS GUI unable to handle a pool with several mirror vdevs? Maybe I need to use a couple of RAIDZ2 instead (4x12 TB + 4x8TB).

    Edit: Creating the pool by CLI and rebooting: Same result. No pool in ZFS GUI, error message pops up, zpool status looks OK.

  • Has this issue been resolved yet. I have just installed omv 5 and zfs and tried to import my pool but get the error below. The pool seems ok when I ssh into the server.


    • image.jpg

      (104.18 kB, downloaded 125 times, last: )

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!