Problem with RAID 5 under OMV 5.0.5

  • Dear all,

    I freshly installed OMV 5.05 (was having debian Buster before but decided to go for a NAS solution this time).
    I am having trouble setuping my RAID 5, I wiped my 3x HDD (6 TB each) and then create the RAID 5.
    However in the RAID management I was expecting to see only 1 unit md0 but I see 4 (the main 1 plus 3 small md1, md2 and md3). I guess it might be because I clicked on apply before assembling was completed. Hence maybe it incorrectly wrote inside the mdadm.conf. But I am not 100% sure.
    Anyway, now my RAID 5 is created but not functioning because I can't create a file system on it. I also tried to delete it and start over, but it fails. Hence, I am planning to do it manually via ssh. It is Debian based, so I imagine it should be ok if I do it manually but I am not sure how much OMV customized the Debian base. Do you think it is feasible folloiwng a Debian tutorial? Any advice?

    Thank you in advance for your help.

  • Don't forget to update the packages first before starting over. The ISO is not up-to-date, but updating a system after installation is general procedure, right? ;-)

    of course, this is the first thing I tried but it did not work either...I had some error message and I had not a lot of time to investigate. Tonight, I will reboot my server and hopefully that will work. Otherwise I will try a first update / upgrade also from the CLI.

  • Eventually after reboot of my server, I could delete the RAID using the web interface and I tried to recreate it using 3 HDDs.

    However, again I see 4 entries while I was expecting a single one (it is still building). Is this normal that it is displayed that way ? Is it the same for you ?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!