OpenVPN can't get it up

  • Hi,


    I try to get up OpenVPN but get this error:


    Could someone say what's wrong?


    I used the same config like on OMV4. OpenVPN is installed from the version 5 testing repo.

  • Where do you even find OpenVPN? I've been looking at guides on how to access my server if I'm not on the network and all of them say to install OpenVPN.


    "To begin, navigate to System>OMV Extras. In the search bar near the top, search for OpenVPN. Select OpenVPN and again near the top, select install."


    OMV-Extras doesn't have a search bar for me (OMV5). Plugins does but OpenVPN is not an option. Is there an up-to-date guide that will let me access my server from outside of my network?

  • After you've installed the plugin, here a sample config:


    005.JPG006.JPG

    Thank you. I got OpenVPN added to my OMV. I then started following this guide. When I get to the last image where it wants me to log in, I get an error.
    Wed Feb 26 16:28:59 2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Wed Feb 26 16:28:59 2020 TLS Error: TLS handshake failed
    Wed Feb 26 16:28:59 2020 SIGUSR1[soft,tls-error] received, process restarting


    It looks like you changed some things that the guide didn't change.


    Where did you come up with your VPN Network Address? That defaulted to something like 10.8.0.0 for me. Should that be my server IP?
    Is the DNS server the IP address of my server (192.168.1.35) or the IP address of my router (192.168.1.1)?
    The guide says to put your public IP in the Public Address bar but you have what looks like a made up website. Which should be here? If it is my public IP, is that what shows up when I log into my router page and look under WAN>IP address?


    Here is my port forward (to make sure that is correct)

  • Port forwarding setting is correct. Target must be the OMV server.


    Quote

    Where did you come up with your VPN Network Address? That defaulted to something like 10.8.0.0 for me. Should that be my server IP?

    No. This is the virtual network ID. Like for me, 192.168.10.0 - If you let this on default (10.8.0.0), your first client in VPN will get 10.8.0.2 (.1 is the VPN server IP)


    Quote

    Is the DNS server the IP address of my server (192.168.1.35) or the IP address of my router (192.168.1.1)?

    Your router, when it acts as DNS server. You also can use a public DNS server like Google (8.8.8.8)


    Quote


    The guide says to put your public IP in the Public Address bar but you
    have what looks like a made up website. Which should be here? If it is
    my public IP, is that what shows up when I log into my router page and
    look under WAN>IP address?

    In my case it's the fqdn of my dyndns provider. It's like my public WAN IP, but as this IP will be changed from time to time, I use DynDNS provider "MyFritz.net" (only if you use a Fritzbox.
    If you want to use dynamically DNS, your router should be able to use such a provider.

  • So what am I messing up? I saved my certificate and added those files to the config folder. Should my DNS server (under DHCP settings) be something different like 8.8.8.8?
    (I changed the VPN network address)


    When I try and connect through the OpenVPN gui I keep getting the error that I posted above. I'm not sure if that's because I'm currently on the same network or if that even matters


    edit: for Gateway Interface I don't have an eth0 option. What I have in that box is the only thing that appears when I click there.

  • Check your net mask. For C-net it should be 255.255.255.0 not 255.255.252.0


    i think you have some misunderstanding what a VPN is.


    The upper settings are for the virtual network itself. For the setting to outside you only need the WANIP informatiom.


    The DNS server is ok with 8.8.8.8, but you could also use the router IP if it acts as DNS server for your home network.


    192.168.1.1 is my router IP. You should use your own, if the IP address differs.

  • I am on a Windows laptop trying to use OpenVPN.


    I know that a VPN makes your public IP address appear like it's from somewhere else. I have Windscribe free account that I use on occasion. The only reason I have OpenVPN added to my OMV server is because the guide I found said that's what I need to access my files if I'm not on the same network as the server. If I'm doing this wrong, maybe you have a different step-by-step guide that I could follow for success? Unless I'm only a step or two away from getting it


    192.168.1.1 is my router's IP. I use FreshTomato for my router firmware.


    After changing the info in the OpenVPN tab, pressing save, then pressing apply...that doesn't restart the service correctly? I have to input your systemctl restart openvpn.service command somewhere and then make a new certificate? Where do I put that command? Into Putty?

  • Still no luck. Is there a better guide to follow than the one I linked above in post #6? Or a better method? My goals are to 1) be able to access my server over the Internet and 2) access my Plex library over the internet.

  • My goals are to 1) be able to access my server over the Internet and 2) access my Plex library over the internet.

    1) Exactly what do you mean by "access my server over the Internet"? Be very specific.


    2) You don't need VPN to access your Plex over the internet.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Still no luck. Is there a better guide to follow than the one I linked above in post #6? Or a better method? My goals are to 1) be able to access my server over the Internet and 2) access my Plex library over the internet.

    No. The guide is exactly this, what I made to get OpenVPN running

  • Please make a screenshot of the config page from your openvpn installation.


    As your error message is "TLS key negotiation failed to occur within 60 seconds" something is wrong with the connection and/or ssl encryption. Please provide a full log file output

  • 1) Exactly what do you mean by "access my server over the Internet"? Be very specific.
    2) You don't need VPN to access your Plex over the internet.

    I want to be able to access my server if I'm not on my home network. (I'm at a friend's house but I want to see my server's files)


    As far as Plex, I figured out that when I thought I created the forwarded port on my Router page, I must have forgotten to click Save. I went back to check that again and it wasn't there. I just added it and re-tested and it shows that I'm available remotely


    Please make a screenshot of the config page from your openvpn installation.


    As your error message is "TLS key negotiation failed to occur within 60 seconds" something is wrong with the connection and/or ssl encryption. Please provide a full log file output

    Not exactly sure what you're referring to. I found this when I click System Information on the left



    If you mean the settings used when I click OpenVPN from the left tab, I have that picture in Post #9. However I changed my Mask to 255.255.255.0 and I changed my DNS Server to 8.8.8.8 per your recommendation than made a new certificate but that didn't work when I was at my girlfriend's house

  • Sorry,


    I mean the Log file content of your client, not the server. Start your client, establish a connection and choose "Log Information". Notpad will be opened. Copy the content (kill personally information before post here)

  • This is what shows when I open my OpenVPN GUI icon, right click the emblem at the bottom right (next to the clock), and click View Log

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!