Several HDD under one sharefolder.

  • To train before a faillure occurs, I decided to create an unionfs and simulate a defective drive.


    I fresh installed OMV5


    Platform : PC, OS Proxmox latest version. i-4670k

    Guest OS : OMV5 updated to latest packages.

    RAM : 4GB 2xCPU core

    HDD : two 2GB VirtuIO hdd, with one EXT4 partition each, 1 physical 1500GB HDD exclusively alocated to the VM.

    I installed :

    flashmemory to avoid access (I removed swap partition)

    resetpermissions

    unionfs


    I created partitions and mounted the x2 hdd

    Using unionfs I manage to create a 2*2GB unionfs

    I added rights to everybody (Access Rightmanagement/Shared Folders)


    Then I tried to create the SMB share using the resulting unionfs and here comes the drama :

    I selected the x2


    "Failed to create the directory '/srv/6023eb2a-130a-44d7-8a4b-d2f8a21a0811/test2hdd/':"


    Details :

    Code
    Erreur #0:
    OMV\Exception: Failed to create the directory '/srv/6023eb2a-130a-44d7-8a4b-d2f8a21a0811/test2hdd/': in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:325
    Stack trace:
    #0 [internal function]: Engined\Rpc\ShareMgmt->set(Array, Array)
    #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
    #3 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('ShareMgmt', 'set', Array, Array, 1)
    #4 {main}



    The SMB share is created, visible in Windows File explorer... but impossible to browse it...


    Any idea please as I googled and only found request without answers.




    Edit: resetting permission on Shared Rights on filesystem before creating the SMB share avoid the error message, but it's still not browsable eventhough I create the smb share with "Public Autorized"

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!