Shared Folders not appearing in /sharedfolders/

  • I have a fresh install of OMV 5 on an SSD, and 3 x 10TB HDD in the system. I've made a mergerfs pool out of 2x10, and the third is for parity with snapraid. Docker config directories will be kept on the root SSD.


    Problem: Shared Folders created via the web gui don't appear in the /sharedfolders/ directory. Searching through the various threads here and on reddit, I've tried troubleshooting the following:


    Mergerfs: an issue (I think was fixed) is regarding mounting the pool before the individual disks are mounted. I haven't had issues with mergerfs mounting, but to take the union filesystem out of the equation, I've tried creating the folders on a disk instead of the pool with no effect.


    I found a thread here about editing the "sharedfolders-xxx.mount" files in /etc/systemd/system/ but interestingly there are none. I suspect this is the problem, but why aren't they being generated?


    :/I don't know what to look at next for troubleshooting. Suggestions welcome!

  • The reason Shared Folders do not appear in the /sharedfolders/ directory is that this behavior has been deprecated in OMV 5.


    Using those directory paths in ways that were not envisioned has been the source of many problems, so this feature was disabled going forward.


    The feature can be enabled if desired, but be advised that the use of those paths within the OMV GUI and in things like Portainer is officially not supported.


    To enable this feature:


    Add the following to /etc/default/openmediavault


    OMV_SHAREDFOLDERS_DIR_ENABLED="YES"


    Then run these commands in a root shell:


    omv-salt stage run prepare

    omv-salt deploy run systemd


    Then reboot.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

    Edited 3 times, last by gderf ().

  • Wow! Thanks for the fast response and great info.


    If referencing /sharedfolders/ causes problems, how should I reference directories in the mergerfs pool? For instance, telling a docker container where my ebooks are kept? I wanted to use the /sharedfolders/ paths for simplicity. When I made the mergerfs pool, I used the union filesystem plugin and it makes a strange string mount point that I can't define (via GUI). Can I define the mount point so it isn't /srv/hug3-l0ng-str1ng-0f-h3x?


    If the answer is to just use the long string, that's fine - it's not that many times to paste it.


    When I didn't use the GUI and made the mount point directly in /etc/fstab, the whole system failed to boot. I tried two different sets of options (and I wish I saved the exact lines to post) but they both caused the failure. The first time I used /srv/pool as the mount point, and the second time I used /mnt/pool. I had to pull the drive and use an external dock with another computer to remove the /etc/fstab entry and it booted up just fine after that. Per usual, it's likely my fault.


    The /etc/fstab entry was something like:

    Code
    /mnt/disk* /mnt/pool fuse.mergerfs direct_io,use_ino,allow_other,minfreespace=50G,fsname=mergerfs 0 0

    I'm sure there are very good reasons for discontinuing the /sharedfolders/ mounting behavior, and I'd rather learn how to do this right going forward.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!