Upgrade issues OMV 3.x -> 4.x .... some issues

  • root@server:~# /usr/bin/fail2ban-client -x start

    ERROR Found no accessible config files for 'fail2ban' under /etc/fail2ban

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR Found no accessible config files for 'filter.d/sshd-ddos' under /etc/fail2ban

    ERROR No section: 'Definition'

    ERROR No section: 'Definition'

    ERROR Unable to read the filter

    ERROR Errors in jail 'ssh-ddos'. Skipping...


    Hi everybody *smiling

    At first - my English is not so good and so i hope, you can understand me. My mother´s language is German.


    I´ve posted my case here

    Upgrade OMV 3.0 -> OMV 4.x

    I´m not so experienced with Linux. A longer time i had fear to do the upgrade procedure. But now OMV 5.x is out and i had fear, that there will be no more upgrade possibility from 3.x to 4.x in the nearest future and i´ll have to do a new installation.

    So i dared now - but there were some issues i´ve posted @Technikaffe.de


    Some issues i could solve with the friends over there - but some issues are actual:


    If i open the GUI there is "Arrakis" v4.1.35-1 installed.

    I had the "php-5" - issue and a lot of mails from my server every day was sent about that. I found, that "apt-get pure "php5*" should solve that.

    "dpkg -l | grep php" now shows me:

    Is that right so far?


    2. problem..... services

    Some of them are coloured red - but for instance NFS seems to be running well?!

    Screenshot-services.jpg


    Could you help me with that?


    3. problem .... Fail2Ban

    If i try to activate any Jail-config - it is not possible ... for instance OMV-WebGUI

    Screenshot-Fail2ban-jails.jpg


    Details:

    Screenshot-Fail2ban-jails-omv-webgui-Details.jpg


    journalctl -u fail2ban -b

  • more about that.....


    /usr/bin/fail2ban-client -x start

    systemctl status fail2ban.service


    Could you help me, please?

    <3

    • Official Post

    Is that right so far?

    Seems ok


    Some of them are coloured red - but for instance NFS seems to be running well?!

    Enable nfs and then disable it. If it has no shares, it isn't hurting anything though.


    If i try to activate any Jail-config - it is not possible ... for instance OMV-WebGUI

    I would purge the plugin and re-install. I've never used it so I can't help much (even though I maintain the plugin).

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Hi ryecoaaron

    Thank you very much for your help. *smiling


    NFS....

    All of my old / actual shares are NFS and they are running. With my Sat-tuner VU+ Duo² everythings seems to be ok.


    Fail2Ban....

    Could you tell me the correct procedure to purge it well - and the same for installing it new, please?

    :)


    <3

    • Official Post

    Could you tell me the correct procedure to purge it well - and the same for installing it new, please?

    Uninstall it from the plugins tab and reboot. Then install it from the plugins tab.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Thank you very much .... i thought in that case it is better to purge it via terminal.

    But .... there are errors, too..... i´ve done as you discribed:

    Screenshot-1.jpg


    Screenshot-2.jpg



    • Official Post

    Unfortunately, I don't use fail2ban but the service can't start. So, I would say there is some config that is bad. I would:


    sudo apt-get purge fail2ban openmediavault-fail2ban

    sudo rm -rfv /etc/fail2ban


    reboot


    Then try re-installing.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!