Access To SMB Share From Windows 10 Fails First Time But OK After Delay

  • Hi,

    I am new to OMV and am trying to use it to replace a failed Seagate NAS

    I have set up OMV on a Raspberry Pi 4, 2GB and am trying to share music files with a Sonos system, music & videos with a Windows 7 PC connected to my TV and use a Windows 10 desktop (Pro, 1903 Build 18362.836) as the "master" with read/write access to all folders.

    I have set up the shared folders and set the permissions as Admin RW, Users RO and Others None

    I have created 3 different users, one for the Sonos with read only access to \Music, one for the windows 7 PC with read only access to \Music and \Videos and one with read/write access for the Windows 10 PC

    I had to add ntlm auth = yes to the samba setup to get the Sonos to work.

    The Windows 7 PC worked without any issues.

    My problem is with the Windows 10 PC -

    On first opening Windows Explorer if I click on Network, wait for it to discover my Raspberry Pi and then click on the Raspberry Pi I get "Windows Cannot Access \\MyPi, Error Code 0x80070035"

    If I keep trying then after maybe a minute I get access and can read and write to the shares.

    If I then close explorer wait a few minutes and then try again I get the same issue

    Can anyone suggest how to resolve this?

  • I don't think that's the issue as I'm not having any issues with the Sonos or the Windows 7 PC

    When I do eventually get access from the Windows 10 PC, the drive on the Raspberry Pi doesn't spin up unless I actually open a file or write to the disk.

    It doesn't seem to be consistent either - sometimes after I have been able to navigate to the shared folders from Windows Explorer and then close Explorer I can check it again after a couple of hours and I can browse the drive immediately with no issues, sometimes it seems to loose the authentication after only a few minuites.

    I have just run an SMBStatus on the Raspberry Pi and this shows the Sonos using NT1 protocol (unfortunately that's all the Sonos will support), the Windows 7 PC using SMB2_10 and the Windows 10 PC using SMB3_11 partial(AES-128-CMAC).

  • Still struggling with this !

    As the Windows 7 PC is working fine with SMB2_10 I tried adding server max protocol = SMB2 to the "Extra Options" in the SMB Settings.
    Still the same issues

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!