SMB Takes too long to start

  • What hardware are you running? Please post full description.

    My system takes about 40 seconds from BIOS to the "OMV beep" (I have installed a lovely buzzer). Boting from a USB stick.

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • Intel Pentium G5400

    ASRock H370M-ITX/ac - 8GB RAM


    My boot device is a Crucial P1 1TB NVMe and I have 2 HDD (1TB) in Raid 1.


    OPM load in seconds.... the problem is that after it loads SMB/CIFS takes too long to come up.

  • Try the syslog, but this sounds/appears to be networking rather than smb, if your issue is accessing an smb share.

    Thank you for the fast replay.

    My problem is not accessing them. It is just that it takes 2 minutes to start. After that everything works as expected. Thus I was wondering is such timings are normal or not


    Regarding network.... that can be a possibility meaning that that I am using DHCP reservation and not a directly assigned IP address.


    Finally I have also issues with monitoring sending emails on boot that it failed to start and then that it was successful..... something takes time to start....


    So I am sending the syslog syslog.txt

  • The output is from the end of your syslog, disregarding the userspace your system start is under 20 seconds, is it normal for smd to take 2 minutes, no, my OMV runs from a USB Flash and takes around the same as auanasgheps does, but I very rarely reboot my server. That's why I asked about the network as smb/cifs is reliant on networking being up.

    Have you added any Extra options to smb/cifs as the option to allow Local Master Browser was removed for WSDD.


    If you look through the log it starts at 9:23 by 9:58 you see this;

    Aug 1 09:58:07 atlas avahi-daemon[490]: Service "atlas - SMB/CIFS" (/services/smb.service) successfully established.


    Further reading down the log Plex locates the shares and starts the daemon.


    These 2 lines also appear in the log;

    Aug 1 09:58:07 atlas avahi-daemon[507]: chroot.c: open() failed: No such file or directory

    Aug 1 09:58:07 atlas avahi-daemon[490]: Failed to open /etc/resolv.conf: Invalid argument


    I have seen reference to resolv.conf being a problem and related to networking in the forum, that's why I asked about networking.

  • Well.... I have not touched resolv.conf.... at least not directly..... inside it, there is only "nameserver 192.168.2.1" and some comments.


    For shares I think I kept is as out of the box....

    Keep in mind that I did a fresh reinstallation to check out the "problem" of SMB & monitoring. I got the exact same thing without any other services like plex installed.

    The only system change I did prior to mounting my volumes, was to change the openmediavault mounting template so that it would mount everything without the "nonexec" options.

  • The only system change I did prior to mounting my volumes, was to change the openmediavault mounting template so that it would mount everything without the "nonexec" options

    How did you do that


    EDIT: I have just set up a raid 1 with a single share on a VM and this was the boot time;

    Aug 1 10:38:11 omv5vm systemd[1]: Startup finished in 5.311s (kernel) + 15.281s (userspace) = 20.593s


    OK mine isn't checking for firmware, but neither do I have a reference to local master browser in the syslog

  • Here's my syslog from today, smb is pretty instant:


    Code
    Aug 1 11:51:03 nas systemd[1]: Startup finished in 3.981s (kernel) + 33.930s (userspace) = 37.912s.
    Aug 1 11:51:06 nas monit[1015]: 'nas' Monit 5.26.0 started
    Aug 1 11:51:06 nas nmbd[1097]: [2020/08/01 11:51:06.224811, 0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
    Aug 1 11:51:06 nas nmbd[1097]: *****
    Aug 1 11:51:06 nas nmbd[1097]:
    Aug 1 11:51:06 nas nmbd[1097]: Samba name server NAS is now a local master browser for workgroup WORKGROUP on subnet 192.168.0.101

    OMV BUILD - MY NAS KILLER - OMV 5.x + omvextrasorg


    Core i3-8300 - ASRock H370M-ITX/ac - 8GB RAM - Sandisk Ultra Flair 32GB (OMV), 256GB NVME SSD (Docker), 3x4TB HDD (Data) - Fractal Design Node 304 - Be quiet! Pure Power 11 350W

  • This video from TechnoDadLife explains how to do it, ignore the fact that it's for OMV4 the process is the same except for omv-mkconf fstab you run omv-salt deploy run fstab

    Thanks for the information.... I tried it already without any luck. SMB light stays RED until 2:03 minutes after boot.

    In fact /usr/share/php/openmediavault/globals.inc has reverted back to original (probably an update). Thus I added the flag in my config.xml and run omv-salt deploy run fstab which updated my fstab and remounted my volumes.


    In fact I do not care much at the moment for the noexec.... I simply had some scripts and I am running them as cron jobs.... thus all.

  • Thanks for the information.... I tried it already without any luck

    That's the correct way to remove the noexec

    In fact /usr/share/php/openmediavault/globals.inc has reverted back to original (probably an update)

    There a re number of files in OMV that cannot be edited manually as they will revert

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!