5.5.7 may have just broken my network config

  • so I just randomly did a apt ugprade today, got openmediavault 5.5.7, and now my network configuration is hosed. The only item I see with a working ip address is a docker0 network address, and I didn't even have docket set up before!


    i'm not sure if I have a restore point or if it was a different item yet in my setup, so I can't promise it was the 5.57 release, but it seems possible. so just throwing it out there.

  • okay i had a quite old snapshot going back to 5.4.2-1


    a simple apt install openmediavault gets me to 5.5.7 and the network seems okay.


    and apt update on everything else seems ok as well.


    so it was something else I was doing. weirdly, probably trying to install the management megaraid storage manager software for my old LSI raid card?

  • lucky you, i am facing this along with a bunch of other people



    Adding pi user to ssh group ...

    removed '/etc/systemd/network/99-default.link'

    Removing network-manager and dhcpcd5 ...

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    Package 'network-manager' is not installed, so not removed

    The following packages will be REMOVED:

    dhcpcd5* raspberrypi-net-mods*

    0 upgraded, 0 newly installed, 2 to remove and 28 not upgraded.

    After this operation, 391 kB disk space will be freed.

    (Reading database ... 59004 files and directories currently installed.)

    Removing raspberrypi-net-mods (1.3.0) ...

    Removing dhcpcd5 (1:8.1.2-1+rpt1) ...

    Processing triggers for man-db (2.8.5-2) ...

    (Reading database ... 58973 files and directories currently installed.)

    Purging configuration files for dhcpcd5 (1:8.1.2-1+rpt1) ...

    Purging configuration files for raspberrypi-net-mods (1.3.0) ...

    Processing triggers for systemd (241-7~deb10u4+rpi1) ...

    Enable and start systemd-resolved ...

    Unblocking wifi with rfkill ...

    Adding eth0 to openmedivault database ...

    IP address may change and you could lose connection if running this script via ssh.

    raspberrypi:

    Data failed to compile:

    ----------

    Rendering SLS 'base:omv.deploy.systemd-networkd.20ethernet' failed: Jinja error: slaves: The value '' doesn't mch the pattern '^(((eth|venet|wlan)\d+|(en|veth|wl)\S+|(bond)\d+)(\.\d+)?,)*((eth|venet|wlan)\d+|(en|veth|wl)\S+|(bd)\d+)(\.\d+)?$'.

    Traceback (most recent call last):

    File "/usr/lib/python3/dist-packages/salt/utils/templates.py", line 400, in render_jinja_tmpl

    output = template.render(**decoded_context)

    File "/usr/lib/python3/dist-packages/jinja2/asyncsupport.py", line 76, in render

    return original_render(self, *args, **kwargs)

    File "/usr/lib/python3/dist-packages/jinja2/environment.py", line 1008, in render

    return self.environment.handle_exception(exc_info, True)

    File "/usr/lib/python3/dist-packages/jinja2/environment.py", line 780, in handle_exception

    reraise(exc_type, exc_value, tb)

    File "/usr/lib/python3/dist-packages/jinja2/_compat.py", line 37, in reraise

    raise value.with_traceback(tb)

    File "<template>", line 20, in top-level template code

    File "/var/cache/salt/minion/extmods/modules/omv_conf.py", line 82, in get_by_filter

    objs = db.get_by_filter(id_, openmediavault.config.DatabaseFilter(filter_), **kwargs)

    File "/usr/lib/python3/dist-packages/openmediavault/config/database.py", line 125, in get_by_filter

    query.execute()

    File "/usr/lib/python3/dist-packages/openmediavault/config/database.py", line 695, in execute

    self._response = self._elements_to_object(elements)

    File "/usr/lib/python3/dist-packages/openmediavault/config/database.py", line 473, in _elements_to_object

    obj.validate()

    File "/usr/lib/python3/dist-packages/openmediavault/config/object.py", line 235, in validate

    self.model.validate(self.get_dict())

    File "/usr/lib/python3/dist-packages/openmediavault/config/datamodel.py", line 200, in validate

    self.schema.validate(data)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 170, in validate

    self._validate_type(value, schema, name)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 224, in _validate_type

    raise last_exception

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 195, in _validate_type

    self._validate_object(value, schema, name)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 300, in _validate_object

    self._check_properties(value, schema, name)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 508, in _check_properties

    self._validate_type(value[propk], propv, path)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 224, in _validate_type

    raise last_exception

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 204, in _validate_type

    self._validate_string(value, schema, name)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 275, in _validate_string

    self._check_pattern(value, schema, name)

    File "/usr/lib/python3/dist-packages/openmediavault/json/schema.py", line 385, in _check_pattern

    % (value, schema['pattern']),

    openmediavault.json.schema.SchemaValidationException: slaves: The value '' doesn't match the pattern '^(((eth|venetlan)\d+|(en|veth|wl)\S+|(bond)\d+)(\.\d+)?,)*((eth|venet|wlan)\d+|(en|veth|wl)\S+|(bond)\d+)(\.\d+)?$'.


    ; line 20


    ---

    [...]

    # GNU General Public License for more details.

    #

    # You should have received a copy of the GNU General Public License

    # along with OpenMediaVault. If not, see <http://www.gnu.org/licenses/>.


    {% set interfaces = salt['omv_conf.get_by_filter']( <======================

    'conf.system.network.interface',

    {'operator': 'stringEquals', 'arg0': 'type', 'arg1': 'ethernet'}) %}


    {% for interface in interfaces %}


    [...]

    ---

    Network setup for DHCP. Reboo

  • votdev

    Added the Label resolved
  • votdev

    Added the Label OMV 5.x
  • thank for this. I ended up messing up my machine with unrelated issues on some virtualized ethernet adapters, and had to go back to the 5.3.9 iso and then back up to 5.5.8. But all seems well.

    thank for this. I ended up messing up my machine with unrelated issues on some virtualized ethernet adapters, and had to go back to the 5.3.9 iso and then back up to 5.5.8. But all seems well.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!