problems with web interface

  • I remain having this problem even after trying everything I have looked up on the internet.

    Output of dpkg -l | grep openm after omv-aptclean:

    I have tried everything listed here in combination with rebooting:

    • Reloading/reinstalling nginx
    • Clearing the web control cache multiple times (as much as I did the omv-aptclean)
    • sudo chown -R openmediavault-webgui:openmediavault-webgui /var/cache/openmediavault
    • Letting the cache.omv\controlpanel\login_js.json regenerate multiple times
    • changing the cache.omv\controlpanel\login_js.json into cache.omv (folder) > controlpanel (folder) > login_js.json
    • renaming cache.omv\controlpanel\login_js.json to login_js.json
    • Downloading someone elses cache.omv\controlpanel\login_js.json and install it
    • Changing my problem from
    Error #0:
    OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/
    Stack trace:
    #0 /usr/share/php/openmediavault/json/ OMV\Json\File->getContents()
    #1 /usr/share/php/openmediavault/controlpanel/ OMV\Json\File->read()
    #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #3 {main}


    Error #0:
    OMV\Exception: Failed to open file (filename=/var/cache/openmediavault/cache.omv\controlpanel\login_js.json, mode=w+). in /usr/share/php/openmediavault/json/
    Stack trace:
    #0 /usr/share/php/openmediavault/controlpanel/ OMV\Json\File->open('w+')
    #1 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    #2 {main}

    and tried multiple possible solutions.


    This error came after I did omv-aptclean. I did the command because there was a login loop.

    Each time when I delete the cache.omv\controlpanel\login_js.json, the login page shows the way it always has been. But once I try to log in, it gives the error again.

    After I did the sudo chown -R openmediavault-webgui:openmediavault-webgui /var/cache/openmediavault command, it magicly worked. I saw my plugins and noticed not all, that were supposed to be installed, were there. For example, nginx, which also couldn't be found in the extensions.

    After about 2 days, the login loop came back and resulted into the same process as I explained here.

    I hope everything you need to help me is given. If not, just ask. I'll answer pretty rapidly.

    Thanks in advance for the help! I really appreciate it.;)

  • You are replying in a thread that is almost four years old, about a version of OMV that is long ago no longer supported, and you haven't said what version of OMV you are running.

    Google is your friend and Bob's your uncle!

    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • You should think about moving to OMV 5.x since 4.x is EOL'd.

    I assume it will fix the error as well than?

    If I would like to update, I could follow your steps.

    Do I need flashmemory to be installed? I don't have that yet and I have no clue how I can install it.

    sudo apt-get --yes install omv-extras-flashmemory does not seem to work. It cannot find the packet/plugin.

    omv-extras should be installed by: sudo wget

    Followed by: sudo dpkg -i openmediavault-omvextrasorg_latest_all4.deb

    And at last: sudo apt-get update

  • I assume it will fix the error as well than?


    Do I need flashmemory to be installed?

    No, it can wait until after the upgrade if your system is installed on flash.

    mv-extras should be installed by:

    If you are on OMV 4.x, that is correct. It isn't correct for OMV 5.x though.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2 plugins source code and issue tracker - github

    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!