OMV SMB, I can connect to smb android phone only when its language is English

  • Hi

    I installed omv 5 on raspi 4. I have a 2 TB one disk. I created file system, shared folders.

    There are 3 users.

    1. Pi user system user

    2. dibekshome sambashare and users have authorization.

    3. Sinan has all the powers

    1.shared folder open to users only for backup

    2. Shared folder 'name=android' users only (trial/test folder)

    3.Shared folder 'name=Public' open to everyone

    As a user, I can do everything on Windows 10.

    But I can only log in anonymously and use the public folder from the file manager of my xiaomi note 9 Pro android 10 phone.

    Although I enter username and password, I cannot see other folders and cannot access samba.

    Although I have used many android applications, I could not solve the problem.

    I created it now to try the Android folder. I created it from the shared folders page and gave read and write authorization to Sinan user via privileges and acl.

    But still I couldn't fix the problem.

    I'll be happy if you can help me.


  • hsdibek

    Added the Label resolved
  • hi.

    I made the language option of the phone in English to add an error screen display. and the problem was resolved.8|

    I don't understand why language was a problem. Now I will try to see if I can do it in Turkish and enter.?(

  • I am facing an absurd problem. When I change the language of the phone to Turkish, I cannot connect with the server address-username and password. the language of the omv interface was english. I did Turkish because maybe it should be the same language, but it didn't happen. could there be a solution from the omv settings? That's why I don't want to use my phone in a different language.

  • hsdibek

    Removed the Label resolved
  • hsdibek

    Changed the title of the thread from “I cannot access private folders on Android” to “OMV SMB, I can connect to smb android phone only when its language is English”.
  • Hi. I tried it from the Huawei p smart 2019 file manager. When the device language is English, I can access all the folders shared over samba with the username and password. but when the device language is Turkish, samba cannot be entered. I tried it on 3 different devices, the problem is the same. i think it's caused by omv. how can i solve it. I installed an omv on raspian buster life. I made the time and region options as Europe Istanbul from the OMV interface. I did not make any settings other than that. I did not use any special characters or Turkish characters in shared folders and users. can you please help. OMV ready files copied but I am not using them over the phone.

  • Hello again,

    I think I am writing it myself, I answer it myself. :S

    I entered the location settings of the system. En_US utf8 did not work tr_TR utf8 did not work.

    The current system location status.

    language Turkish

    region europe

    city Istanbul

    root @ raspberrypi: / # locale

    LANG = en_TR.UTF-8


    LC_CTYPE = "C.UTF-8"

    LC_NUMERIC = "C.UTF-8"

    LC_TIME = "C.UTF-8"

    LC_COLLATE = "C.UTF-8"



    LC_PAPER = "C.UTF-8"

    LC_NAME = "C.UTF-8"

    LC_ADDRESS = "C.UTF-8"




    LC_ALL = C.UTF-8


    root@raspberrypi:/# localectl status

    System Locale: LANG=tr_TR.UTF-8

    VC Keymap: n/a

    X11 Layout: gb

    X11 Model: pc105

    When the device language of the phone is Turkish, I cannot log in samba with the username and password.

    When I connect anonymously I can only see public.

    I did not use Turkish characters in any of the folder, file path, user name, password.

    I could not solve the problem somehow ???;(

  • hsdibek

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!