[solved] No more webgui

  • Hi,

    Since few days i hadn't webgui panel. It begin when i did a "sudo apt upgrade" that broke some dependencies. I tried to fix that by "Fix-Broken". Then nginx failed to start.

    I tried to reinstall it but i got the message that nginx can't be configured and can't start.

    Command "sudo nginx" give :

    nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)

    omv-firstaid give :

    Failed to connect /var/lib/openmediavault/engined.sock: [Errno 2] No such file or directory

    Sudo dpkg --configure -a give :

    I browsed internet, and found no solution.

    Can you help me.

    Thank for your time.

  • I get back the gui.

    I did :

    apt purge nginx nginx-full openmediavault
    sudo service apache2 stop
    apt install nginx
    then :
    apt install openmediavault

    Now it's working, but i have " Failed to connect to socket: No such file or directory" at login. I will investigate.

    bye bye

    Edit : "failed to connect [...]or directory" solved with this below into the ssh terminal :

    # systemctl unmask openmediavault-engined.service
    # systemctl enable openmediavault-engined.service
    # systemctl start openmediavault-engined.service
  • alfly

    Changed the title of the thread from “No more webgui” to “[solved] No more webgui”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!