Disks desappeared

  • Greetings,

    I had my OMV 5 running smoothly for quite a while. on a RP4 4GB.
    The pi is on a DeskPi case.

    3 HDD:

    1 SSD internally
    2 external USB HDD (USB3)

    Suddenly other devices in my LAN that use OMV shared folder, give me errors.
    - I check the OMV DISKS section and I see nothing but SDCARD

    - I check fdisk -l and nothing but sdcard comes out

    - checked lsub and I do have the USB present (to eliminate the option that USB are not detected anymore)


    Bus 003 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

    Bus 003 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub

    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    What did I try?

    I tried to take the external disks out of usb hub and attache them directly to the box usb -> no joy
    I tested if the HDD works by mounting them on my linux laptop -> joy (they work fine)


    Conclusion:

    No idea what to do to have my disks working again.
    Any help is welcome


    System:

    Raspberry pi 4b 4GB

    5.10.60-v7l+

    armv7l

    fdisk -l:

    Device Boot Start End Sectors Size Id Type

    /dev/mmcblk0p1 8192 532479 524288 256M c W95 FAT32 (LBA)

    /dev/mmcblk0p2 532480 31116287 30583808 14.6G 83 Linux




    Thank you

  • Do your disks show up in the OMV GUI under the Disks tab, or under the File Systems tab?

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • Is the HUB that you're using this one: Quick Review: Cheap Unbranded 4-port USB 3.0 Hub from eBay | Gough's Tech Zone (goughlui.com)

    How are you powering the Hub? With external power or via the Pi USB?


    The DeskPi (from what I saw on the WEB) is somewhat similar to the Argon One case, which means your SSD is using 1 USB3.0 port (and beeing powered by the Pi).


    Are you using a proper/decent power supply to feed all of that? (Either the original Pi charger or a really good one that provides the 5V/3A specially on heavy loads)


    Post the output of:

    sudo dmesg | grep voltage

    cat /var/log/syslog | grep voltage

  • Hi,

    I use the original raspberry pi 4b power adapter.

    The usb3 hub is externally powered

    but your command does gives underpower results:


    [ 3439.623123] Under-voltage detected! (0x00050005)

    [ 4076.108684] Under-voltage detected! (0x00050005)


    This is odd.

    Also, I went on for months without any issue!

    Do you think is a power only?


    I tested to take all the external disks (and the hub) out and still I dont see my internal SSD


    Correction: after restarting OMV5 without my externally powered usb 3 hub, my internal disk does show up.

    HOWEVER... the voltage given is still not goo:


    [ 96.473666] Under-voltage detected! (0x00050005)

    [ 115.193952] Under-voltage detected! (0x00050005)

    [ 125.594109] Under-voltage detected! (0x00050005)

    [ 412.635861] Under-voltage detected! (0x00050005)


    Also an other correction, the powersupply I use is not from raspberry pi but from DeskPi (I have several Pi and I got confused)

    DeskPi output: 3.5-6.5V=3A, 6.5-9V=2A, 9-12V=1.5A

    Original Raspberry pi power supply : 5.1V=3A

    sudo dmesg | grep voltage does not report anything at all. is that a good sign?

  • So, after Soma suggestion, I did few tests.

    Turns out that when I switch the power supply with the original raspberry pi one, it works fine and all my disks are back.
    The command

    sudo dmesg | grep voltage

    returns nothing but a prompt. I assume this is good news.

    What is unclear to me is that the DeskPi power supply seems to be stronger than the original Pi (see specs above). Yet not working well after all.
    Not even with one internal disk.
    This will be certainly reported at DeskPi or other forums.


    One more odd thing is that it worked well for several months. Suddenly the issues appeared. I hope I will not have the same with the original RPi power supply.


    Thank you for helping me.

    :thumbup::thumbup::thumbup:

  • kattivius

    Added the Label resolved
  • There where issues with some Pis (version 1.1 if I'm not mistaken) that didn't take well "foreigner" power suplies.

    It was solved on the next batches.


    But, nonetheless, it's always recommended to use the original one.


    The command from dmesg, I really don't know if it would show anything about the under voltage but the syslog is important just the same.


    Try to keep an eye on it, even with the original Pi power supply.

    They don't deal well with many things attached and consuming, ;)


    Glad it's working

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!