CMB/CIFS slow or breaking on iOS (Fine on win 10 & MacOS)

  • Hello all,

    New to OMV & networking, but fairly tech savvy otherwise. I have created a shared folder and it works fine. I based my setup mostly on this guide.


    On my iPhone, weather I am using the "Files" app or through PhotoSync, I'm having issues. If I try to upload photos to the server, I get:

    "The operation couldn't be completed/ Operation canceled"

    When I try though the PhotoSync app, things are painfully slow. Photos spend a fraction of a second uploading but most of the time just sitting there idle. Getting about 1MB/s equivalent when I get 10MB+ on both my Windows PC and Mac notebook.


    What would be the right way to go about diagnosing this? Thanks so much in advance!

    Running on an RPi 3B, wired ethernet (network configured by my apartment, unfortunately).

  • Agricola

    Approved the thread.
  • This is a much better guide.


    I uploaded the PhotoSync app on an iPhone 8 and it has worked fine for me for a couple of days. You may have permission issues on the folder you are trying to load to.

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!