IPv6 just not working

  • Well after reading hundreds of posts about getting ipv6 to work in OMV it would appear this is just another dead-end. Why can this not be configured through the GUI. Surely this has been fixed/sorted. In the real world of mixed environments where Windows devices are a necessary evil IPv6 is crucial for connection through LANs VPN etc. Can anybody tell me if this is at all possible .. surely it must be.

  • You want to go from this:

    To this?

    What's stopping you?

    Unless you're already connected via WiFi and you're trying to edit the wlan0 interface.

    OMV (at least v6) will block any edition, otherwise you might be without connection.

    Just run omv-firstaid and configure the WiFi there and accept ipv6 also.

  • Very nice pics - pity they don't reflect the fact that what ever you select for IPv6 - DHCP, AUTO, STATIC -none actually work. Using an onboard nic for LAN but cannot get an IPv6 for OMV and from the 100s of posts on forums I am not alone. Should be simple but not.

  • For starters, there's something that you and "the 100s of posts on the forum" should consider: the hardware is controlled by Debian.

    If there's any issues with the hardware not working has it should, then it's time to dig in on Debian's forums or HowTo's or FAQs to see what can be done to solve the problem.

    search results - debian 10 enable IPv6 (bing.com) For Debian 10/OMV5

    search results - debian 11 enable IPv6 (bing.com) For Debian 11/OMV6

    Although I only started using OMV on it's 5th version, one of the things I "read" (it's showned on the Guide for SBCs, at least) was to disable IPv6.

    And it works just the same.

    Hell, I don't even know (or do I care) what is the advantage of using IPv6 on a home NAS for personal use with, and this is the "Holy Graal" of it all:

    A free software made by a few enthusiastics on they're free time without asking for nothing in return.

    Saying again, It's FREE so, if it doesn't have all the functions you need, go find a different software that has them but, be willing to pay for it because it will probably won't be free.

    Don't take this personal, but when people start arguing why this or the other issue is not solved, it really hit's a nerve.

    Specially when they don't add any solution to the case.

    Why can this not be configured through the GUI. Surely this has been fixed/sorted

    If you know how, please, DO SHARE.

    I'm sure the OMV developer(s) will appreciate the help, ;)

  • Sorry you took my comments the wrong way - if IPv6 is not functional then remove it. I realise OMV is free and of course some features are just not available. I would expect however that a feature listed and able to be configured to some degree actually works otherwise remove it. The reason IPv6 is important is that MS in their infinite wisdom make IPv6 the dominant protocol for network browsing. Right wrong or otherwise that's the situation. On a LAN with Windows PCs it affects browsing etc to the OMV. A fix? Not to my knowledge - I just get around it by using static IPv4 on OMV and never address it by name. Windows automatically assigns a stateless IPv6 to a NIC without any manual configuration and does not require any DHCPv6 server. Back to point - I was not criticising the developer of OMV - what the developer has achieved is amazing and has the simplest and most functional sharing via a CUI i have come across. Way past my capabilities and very grateful for such a great tool. But again if IPv6 is not functional then remove it. The annoying thing for me is when half hearted solutions are posted that have obviously not been tested and are touted with little or no knowledge - your pics showing the config for IPv6 set to DHCP is of no help whatsoever - anyone can see the option and select different modes - BUT I noticed you didn't show the expanded screen shot that shows that no IPv6 address was assigned. In any case I was not criticising the developer and I guess there is no solution because it just doesn't work. If someone does actually have a working solution then I would love to hear about it also. Still love OMV ...

  • OK, let me put this on a different level.

    The case scenario I showed on the pictures was a WiFi connection on a Pi 4 running OMV6 with Debian 11. (Connected to a WiFi repeater that I don't have access to manipulate, if it matters)

    Changed to wired connection (on the job but also, without access to manipulate it).

    Ran omv-firstaid to configure the eth0 again, and accepted both DHCP IPv4 and DHCP IPv6.

    Running ip addr, I get this:

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether dc:a6:32:54:5e:fd brd ff:ff:ff:ff:ff:ff
        inet brd scope global dynamic eth0
           valid_lft 860819sec preferred_lft 860819sec
        inet6 fe80::dea6:32ff:fe54:5efd/64 scope link
           valid_lft forever preferred_lft forever

    So, the way I see it, inet6 is configured. (Or not, don't care)

    ip addr show dev eth0 | awk '{if ($1=="inet6") {print $2}}'


    But, this will be a "Ouroboros" conversation that won't go nowhere.

    So, I'll stop here.


  • The plot thickens - I noticed your comment

    "For starters, there's something that you and "the 100s of posts on the forum" should consider: the hardware is controlled by Debian."

    and thought I would delve deeper - in OMV terminal IPv6 is indeed active


    root@fs09:~# lsmod | grep ipv6

    nf_defrag_ipv6 24576 1 nf_conntrack

    root@fs09:~# cat /proc/net/if_inet6

    fe80000000000000505400fffe794dda 0a 40 20 80 macvtap0

    fe80000000000000523eaafffe1361ae 02 40 20 80 ens3

    fe8000000000000004e580fffed6caf3 08 40 20 80 vethf376651

    fe8006c3ce53a8900000000000000001 03 40 20 80 eno1

    fe8000000000000000424bfffed3d895 06 40 20 80 docker0

    00000000000000000000000000000001 01 80 10 80 lo



    root@fs09:~# [ -f /proc/net/if_inet6 ] && echo 'IPv6 ready system!' || echo 'No IPv6 support found! Compile the kernel!!'

    IPv6 ready system!



    and indeed from the terminal the OMV (fs09) can in fact be pinged for ipv6


    root@fs09:~# ping6 fs09 -c 4

    PING fs09(fs09 (fe80::523e:aaff:fe13:61ae)) 56 data bytes

    64 bytes from fs09 (fe80::523e:aaff:fe13:61ae%ens3): icmp_seq=1 ttl=64 time=0.034 ms

    64 bytes from fs09 (fe80::523e:aaff:fe13:61ae%ens3): icmp_seq=2 ttl=64 time=0.047 ms

    64 bytes from fs09 (fe80::523e:aaff:fe13:61ae%ens3): icmp_seq=3 ttl=64 time=0.049 ms

    64 bytes from fs09 (fe80::523e:aaff:fe13:61ae%ens3): icmp_seq=4 ttl=64 time=0.034 ms

    --- fs09 ping statistics ---

    4 packets transmitted, 4 received, 0% packet loss, time 77ms

    rtt min/avg/max/mdev = 0.034/0.041/0.049/0.007 ms


    so what am i missing ?? obviously knowledge of how linux works ..

    the ping6 to fs09 is returning the ipv6 address for ens3 which is not configured in OMV (fs09) but is configured in Windows VM in KVM

    if i ping VM it returns the correct ipv4 address configured in Windows but if I ping6 the VM it says unreachable ...

    confused is an understatement ....

    if anyone has some insight as to what is happening here I would love some input.

    • Official Post

    It really amazes me that the OMV GUI doesn't work here. I am convinced that OMV only runs debian commands to enable or configure IPv6.

    I suspect that the real problem must be with your hardware. Maybe debian doesn't have the necessary drivers if it's very new hardware. And this doesn't seem like a very common function. I would continue this way.

    In any case I firmly believe that what is posted here should help anyone who reads it later. And anyone who publishes should keep this in mind. There are many ways to seek help, you choose how you do it.

    For this thread to be useful for others maybe you should give more information, what is the model of your NIC, for example, what hardware do you run OMV on. This thread as it is is only useful for you, it does not motivate you to reply.

    A later post with the result of your research would also be helpful. If the result is favorable, you will help whoever has your NIC. If the result is negative someone will read it and will not buy this NIC.

    I would also change the title of the thread and call it "IPv6 Configuration on Model XYZ123 NIC" or "Problems with XYZ123 and IPv6 NICs" .... The information is useful, you don't need to know how to program to help.

    Lastly, I just want to say that no one here has any obligation. The help that is provided is free. I recommend this reading. https://openmediavault.readthe…html#when-things-go-wrong

    Hope you figure it out, good luck.

  • Hi Soma - good one .. cyclic conversation .. however you did the job .. excellent work and grateful for you persistence with my ramblings.

    I assume that the answer to the very first question relating to the OMV GUI configuration of IPv6 is that is does not work. However if done through omv-firstaid works like a charm .. just out of interest is there a technical reason for this?? GUI is a no and omv-firstaid is a yes??

    Again sincere thanks for the solution I was looking for.

  • Just to give other readers some insight - old HP Z210 Workstation with onboard NIC running OMV on an SSD hard disk, created a Windows 10 Pro VM in KVM and installed a second physical NIC for the VM. Created shares in OMV to a 6Tb HD and another to a 8Tb HD than can be accessed by OMV and VM and obviously the network which is predominantly Windows, Run DeltaCopy to backup a Windows Fileserver and several desktops and laptops. Probably strange hey ...

    My next learning quest is to install Windows 10 Pro as a host on another Z210 and create an OMV VM in VirtualBox as well as a Ubuntu Desktop VM - just to play and see what other mindboggling network issues I can create ...

    Hope someone finds it useful or at the very least entertaining.

  • Thanks chente - very good constructive post ... got there in the end - basically didn't realise that just because the OMV GUI can't configure IPv6 omv-firstaid certainly can - such a simple fix.

  • Hi Soma - excellent reply .. did you configure IPv6 as DHCP or auto?

    Since these are some test Pis I carry when travelling, it's DHCP all the way, ;)

    But, as for the auto part, if you mean this:

    Then, I choose "Yes" and "No" to Wake-on-LAN" (the Pi doesn't support it anyway, at least without a HAT, AFAIK)

    Or, you meant DHCP or Static?!?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!