Odroid HC1 armbian update report

  • I updated my HC1 to OMV 6.x RC1 using omv-release upgrade. I got the following errors during the upgrade:

    Code
    [ERROR ] /lib/python3/dist-packages/salt/modules/network.py does not exist
    [ERROR ] /lib/python3/dist-packages/salt/fileserver/roots.py does not exist
    [ERROR ] {'out': 'highstate', 'ret': {'odroidxu4': {'file_|-patch_network_module_pr_59829_|-/lib/python3/dist-packages/salt/modules/network.py_|-patch': {'name': '/lib/python3/dist-packages/salt/modules/network.py', 'changes': {}, 'result': False, 'comment': '/lib/python3/dist-packages/salt/modules/network.py does not exist', '__sls__': 'omv.patch.default', '__run_num__': 0, 'start_time': '15:47:14.873969', 'duration': 3.751, '__id__': 'patch_network_module_pr_59829'}, 'file_|-patch_fileserver_root_pr_60536_|-/lib/python3/dist-packages/salt/fileserver/roots.py_|-patch': {'name': '/lib/python3/dist-packages/salt/fileserver/roots.py', 'changes': {}, 'result': False, 'comment': '/lib/python3/dist-packages/salt/fileserver/roots.py does notexist', '__sls__': 'omv.patch.default', '__run_num__': 1, 'start_time': '15:47:14.878254', 'duration': 2.864, '__id__': 'patch_fileserver_root_pr_60536'}}}}

    Moreover, the armbian source seems to have remained at buster if apt output is to be trusted. Is this normal?

  • The web UI warns about needed config changes, but throws an error when attempting to apply them:


    Moreover, there appears that there are some more buster/usul leftovers:


  • votdev

    Added the Label resolved
  • votdev

    Added the Label OMV 6.x (RC1)
  • votdev

    Added the Label Upgrade 5.x -> 6.x
  • This has been a useful thread as I have just updated a rpi on stock/min config OMV5 that I use as a backup server. I had similar issues upgrading to OMV6 and have updated the apt sources using the sed commands above.


    I'm not sure if I need to install usrmerge as everything seems ok but I know the package has not been installed.


    the output from readlink -f /lib is.... /usr/lib


    So I think that means the system has been converted and so I don't need to install usrmerge. Correct?

  • I don't think so, you only need usrmerge if your folders are not merged. My original install was OMV 4, it looks like the merge was not done when I upgraded to OMV 5 for some reason.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!