ZFS Error after upgrade Kernel to 6.0.0-0.deb11.2-amd64

  • Im using ZfS in openmediafault extras (6.012); With kernel 5.19 anything is ok.


    After Upgrade to Kernel 6.0.0-0.deb11.2-amd64 (apt-get dist-upgrade in Terminal) - ZFS doesnt work.


    modprobe ZFS :

    root@openmediavault:~# /sbin/modprobe zfs

    modprobe: FATAL: Module zfs not found in directory /lib/modules/6.0.0-0.deb11.2-amd64


    Please help me to activate zfs. What can i do?

    • Official Post

    What can i do?

    The zfs version in the debian repos does not support the 6.0 kernel yet. I would use the proxmox kernel. install the kernel plugin to make that easy.

    omv 6.2.0-1 Shaitan | 64 bit | 6.1 proxmox kernel

    plugins :: omvextrasorg 6.1.1 | kvm 6.2.8 | compose 6.6.1 | cputemp 6.1.3 | mergerfs 6.3.5 | zfs 6.0.12


    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Bonjour,


    J'ai le même problème, malgret plusieurs topic, rien ne marche. J'ai essayé d'installer le noyau proxmox 5.19 , j'ai une erreur.

    pour le pluggin kernel de OMV extra, il s'est installé mais quand je vais dans la section j'ai un message d'erreur.

    Quand je vais dans la section ZFS pour regarder le POOL, j'ai un message d'erreur aussi.

    modprobe : FATAL : Module zfs introuvable dans le répertoire /lib/modules/6.0.0-0.deb11.2-amd64


    Code
    Tous les paquets sont à jour.
    root@omv:~# apt install pve-kernel-5.19
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances... Fait
    Lecture des informations d'état... Fait
    E: Impossible de trouver le paquet pve-kernel-5.19
    E: Impossible de trouver de paquet correspondant à l'expression rationnelle « pve-kernel-5.19 »
    root@omv :~#



  • root@omv:~# apt install pve-kernel-5.19

    This is not how you should install it.


    Make sure you have the kernel plugin installed:



    Then go to the kernel page and click the dropdown button with the down arrow and select the proxmox kernel you want:


  • Bonjour, merci pour votre réponse.

    La première fois que le plugin ne voulait pas s'installer. Après avoir recommandé celui-ci a fonctionné. Par contre quand je fais comme vos images, j'ai un message d'erreur.


    sur le tableau de bord, je suis passé au kernel 5.19, mais j'ai toujours le message d'erreur pour le ZFS



  • After installing the proxmox kernel, did you, by any chance, rebooted to apply the new kernel????

    Try running '/sbin/modprobe zfs' as root to load them.

    And if you read this, did you followed it?


    Or better yet, what is the output of:

    uname -a



    Or the screenshot of system info on the dashboard:

  • J'avais re-démarré.

    j'ai remarqué que vous etes en 5.19.17-1.pve, moi non. peut être dois-je changer ?

    ensuite il y a des mises à jours, avec du ZFS, peut être qu'il faut les faire ?

  • Maybe I need to change?

    Click on the PVE kernel 5.19 to select it:


    Then, click on the clock to boot with it:

  • macom

    Added the Label resolved
  • macom

    Added the Label OMV 6.x

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!