docker not working since omv-upgrade

  • *** This is for amd64 and i386 only ***

    Here is the solution to disable apparmor on the system and it worked on my test system (not harmful since apparmor package is not installed):

    Code
    sudo mkdir -p /etc/default/grub.d
    echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=0"' | sudo tee /etc/default/grub.d/apparmor.cfg
    sudo update-grub
    sudo reboot

    Taken from: https://wiki.debian.org/AppArmor/HowToUse#Disable_AppArmor


    I'm on a fresh install of omv on bare metal, I updated/upgraded everything both through apt-get and through the web ui. I installed dockers and then portainer. I ran the commands, however it didn't work for me. I tried ports 9000 8000 9334 both through http and https. I am not technical enough as to what might be the problem.


    I'm on a BIOS install and I utilized version 6.0.24


    I'm not sure if the problem is that I ran the commands through ssh or something of the nature. Any help would be apprecieate.

  • I'm on a fresh install of omv on bare metal, I updated/upgraded everything both through apt-get and through the web ui. I installed dockers and then portainer. I ran the commands, however it didn't work for me. I tried ports 9000 8000 9334 both through http and https. I am not technical enough as to what might be the problem.

    So can you describe the problem, screenshots error messages etc.

    OMV 6 Lenovo M910q - Intel(R) Core(TM) i5-6500T CPU @ 2.50GHz 16GB RAM

  • Same as OP, portainer can't be reached. Should I do another reinstall and follow the same steps? I doubt it would change anything, though.

    mmm... I was going to bite the bullet finally and upgrade from v5 to v6 as a fresh install. Judging by these comments, think I'll just hold fire and stick with v5 that has no problems for me!

    OMV 6. ASRock J5005-ITX, Crucial 8GB Kit (4 GB x 2) (DDR4, 2400 MT/s). Fractal Design Node 304. Crucial BX500 128 GB system drive. 4 X WD Red 6 TB. 2 X 8 TB external Western Digital Elements USB.

  • I had to go back to Kernel 5.19 as a temporary workaround to make my system boot.


    I'm not an expert on Linux. Will this change take effect if I'm working on Kernel 5, apply the changes and then below, and then boot Kernel 6?

    *** This is for amd64 and i386 only ***

    Here is the solution to disable apparmor on the system and it worked on my test system (not harmful since apparmor package is not installed):
    Code sudo mkdir -p /etc/default/grub.d echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=0"' | sudo tee /etc/default/grub.d/apparmor.cfg sudo update-grub sudo reboot

    • Official Post

    Will this change take effect if I'm working on Kernel 5, apply the changes and then below, and then boot Kernel 6?

    The parameter to disable grub is being passed to all kernels.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • hi guys I thought something wrong with my omv 6 so I reverted to my good backup using fsarchiver, after boot and updated it started wonky again. so I apply the update grub solution to disable apparmor. now everything is good. however, will this break anything for future updates? just curious TQMV

  • Had the same issue as people above. The grub fix from above fixed my docker but I still cannot access the web UI of portainer. the status for portainer is 'Created'. Changed the ports to 8001/9001, still nothing.

    After the Fix i install Docker and Portainer new. Now ist running

    • Official Post

    will this break anything for future updates?

    No. It is just disabling apparmor at the OS level. By default using the OMV iso, apparmor is not even installed.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • I applied the "fix" rebooted. Still no portainer, then uninstalled Docker/Portainer and tried to reinstall and I get errors?
    Now it cannot pull or find portainer and docker installed with errors. Confused at this point, I am hoping I do not have to reinstall fully at this point.

    OMV Version: 6.9.12-3 (Shaitan) Kernel: Linux 6.1.0-0.deb11.13-amd64 Proxmox VM

    Services: MiniDLNA | File Server (streaming and file transfers that's it.)
    System: HP Pavillion 595 | I7-8700 ( 2 vCores) | 2.1 GB Ram | 32GB VM Sys Drv | 5TB USB Media Drive | Jan 24'

  • Same issue here. Tried pulling recent image and got this error:


    Quote

    Starting portainer/portainer-ce ...
    1cfb006407dd840340e32f54ace41adb4a0c14e0a4d077914db7ac0aaca3ac07
    Something went wrong trying to pull and start portainer ...

    END OF LINE



    All of my dockers are down (qbt, Plex, files...). Any ideas when can we expect a reaction in the form of a system update?

  • ryecoaaron official fix on page 1 worked for me on my OMV6 running as a VM on Proxmox. Waited over a week to apply though just in case other solutions surfaced.


    My Steps were:


    1) Ran a Proxmox backup of the VM first

    2) Copy and pasted the fix into putty

    3) Applied the updates in OMV webgui, and rebooted.


    Everything came back up as normal and no issues accessing Portainer.


    I'm running on an AMD Ryzen 5900x in case that matters to anyone.

    • Official Post

    Any ideas when can we expect a reaction in the form of a system update?

    System update for what? Different systems require different updates. And just to say this again, this is not an OMV issue. omv-extras installs docker-ce as a convenience but you would have the same problem if you installed docker using the docker install script. We can't help that docker made a big change. The main solution is on post #9 in this thread.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Quote

    We can't help that docker made a big change

    So is this something that will happen regularly? Parts of the system if maintained elsewhere will break parts of the system? Just wondering because after following the fix I still do not have docker or portainer. Also miniDLNA is not working. Just a basic NAS now. How much of docker is infused with the system?

    OMV Version: 6.9.12-3 (Shaitan) Kernel: Linux 6.1.0-0.deb11.13-amd64 Proxmox VM

    Services: MiniDLNA | File Server (streaming and file transfers that's it.)
    System: HP Pavillion 595 | I7-8700 ( 2 vCores) | 2.1 GB Ram | 32GB VM Sys Drv | 5TB USB Media Drive | Jan 24'

  • How much of docker is infused with the system?

    Has much as you (the user) applies on it (the system).

    OMV at it's core doesn't use docker.


    So, use docker on a seperate device and it won't break your system.

    Just a basic NAS now

    You still have NFS, SMB, FTP, RSYNC, SCHEDULED TASKS, and so on and on and on ...

  • Quote

    So, use docker on a separate device and it won't break your system.

    In other words, what as working before which technically wasn't supported although working for years sorry your SOL. I understand now thank you for that final push on to something better.

    OMV Version: 6.9.12-3 (Shaitan) Kernel: Linux 6.1.0-0.deb11.13-amd64 Proxmox VM

    Services: MiniDLNA | File Server (streaming and file transfers that's it.)
    System: HP Pavillion 595 | I7-8700 ( 2 vCores) | 2.1 GB Ram | 32GB VM Sys Drv | 5TB USB Media Drive | Jan 24'

  • thank you for that final push on to something better.

    Glad I could help, 😉

    • Official Post

    In other words, what as working before which technically wasn't supported although working for years sorry your SOL.

    All software has bugs. No one said you were SOL. And I have been supporting docker if you can't tell. But what we can't control is when docker makes major changes. We have to come with solutions and there a few in this thread. OMV doesn't have hundreds of devs working on the product and everyone is a voluteer. Using OMV might require a little effort some times. And if your server can't handle any problems, you should be testing updates on a second server.

    So is this something that will happen regularly?

    Hopefully not. This is the first big docker change that I can remember since adding docker functionality via plugin to OMV. Have you never had a problem with a Windows update? I don't believe anyone who says no,


    Parts of the system if maintained elsewhere will break parts of the system?

    Bad Docker changes only break docker. Portainer runs in docker.

    I understand now thank you for that final push on to something better.

    Good luck. I think you will find problems in every solution you try at some point or another.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    I am going to close this thread. Solutions presented are working. If you are still having issues, please start a new thread.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!