omv-extras 6.3 / openmediavault-compose 6.7

  • Ok, my issues are gone - seems that I have had misconfigured the backup option from compose plugin? I filled zero for max size, could be the source?

    After I disabled the backup option and deleted the folders from the shared folder all is back on the green side:


    • Official Post

    my issues are gone - seems that I have had misconfigured the backup option from compose plugin? I filled zero for max size, could be the source?

    If you set it to 0, then then backups can backup unlimited amounts of data. If you have a container that has your media collection as one of the volumes and it isn't mounted ro, then you could be backing up your media collection over and over. That is why I added the limit.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • If you set it to 0, then then backups can backup unlimited amounts of data. If you have a container that has your media collection as one of the volumes and it isn't mounted ro, then you could be backing up your media collection over and over. That is why I added the limit.

    Yeah, jellyfin was grabbing 3.75 TB in the end on the backup destination (like you said it was a backup loop). Now its ok. Thanks for quick answers and patience for user generated issues. :)

  • I just set up a blank OMV installation in my Raspi and struggling a bit with the usage of compose. I followed the guide. Here is where i was strugglling:

    Quote
    2. Create a folder called "compose". If this is a new install, create a folder called "containers".

    Does this mean when it is a new install i need both folders? Or does it mean I need the containers folder instead of a compose folder?


    Quote

    If you are setting up for the first time, you'll also need the absolute path to this folder (click the 4 squares in the upper right, put a check next to absolute path)

    To be more precise, the 4 squares icon is in the shared folders tab not in the "create shared folder"-tab.


    The guide says nothing about the mandatory fields of User and Group. I created a user account called "compose_user" and choose the group "users".


    Between step 12 and 13: Is it necessary to apply changes after saving and before restarting? [applying before restarting ends in an error message]


    Quote


    After docker starts and says it is installed and running..


    To be more precise: You can see the status: Compose=>Settings => Docker => Status.

    • Official Post

    Does this mean when it is a new install i need both folders? Or does it mean I need the containers folder instead of a compose folder?

    You need both. One is where the compose files will live. The other is where docker storage lives. They shouldn't be the same.


    I recommend reading this - https://wiki.omv-extras.org/do…v6_plugins:docker_compose

    The guide says nothing about the mandatory fields of User and Group. I created a user account called "compose_user" and choose the group "users".

    Those are new fields. Leaving them at the default settings is a better idea unless you have a good reason to change them. 99.9% of users do not have a good reason to change them.


    Between step 12 and 13: Is it necessary to apply changes after saving and before restarting? [applying before restarting ends in an error message]

    Depends on what the error message is.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Quote

    Those are new fields. Leaving them at the default settings is a better idea unless you have a good reason to change them. 99.9% of users do not have a good reason to change them.

    You can not leave them default. It is mandatory to select an user account and a group. YOu can not leave them empty. Maybe it should be in the getting started guide.

    Quote

    Depends on what the error message is.

    In my case restart before applying was the only working way. Maybe it should be in the getting started guide. Others might be confused as well as me :)

    • Official Post

    You can not leave them default. It is mandatory to select an user account and a group. YOu can not leave them empty. Maybe it should be in the getting started guide.


    In my case restart before applying was the only working way. Maybe it should be in the getting started guide. Others might be confused as well as me


    You can read it here. https://wiki.omv-extras.org/do…s:docker_compose#settings

    You don't need any user to configure the plugin.

    • Official Post

    Are you sure you are on the latest version?

    In my settings tab it is not possible to save when user / group are empty? Look @ my screenshot.

    The usual thing is to define the root user in that field. That way the files will be owned by root and no one will be able to read them.

    Unless you have some special reason to change that, you should set root user in those two fields.

    • Official Post

    In my settings tab it is not possible to save when user / group are empty?

    I thought I read that by default those two fields were already owned by the root user. I'm not sure why you have them blank.

    • Official Post

    you mean "IP Range"? Because in my screenshot I do have a gateway. I usually setup my IPs manually in the compose file, I do not want them to be dynamically allocated

    Yes, it doesn't matter. The current code will skip adding them if all three fields are not populated. I will fix it but just give me time.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    You can not leave them default. It is mandatory to select an user account and a group. YOu can not leave them empty

    I wrote the plugin. I know what works. root should be the default for group and user.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Minimal update in repo now.

    Code
    openmediavault-compose (6.9.5) stable; urgency=low
    
      * Allow more flexibility in network creation
      * Ensure default user, group, and permissions are set in Settings tab

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Quote

    I wrote the plugin. I know what works. root should be the default for group and user.


    I appreciate your fantastic work. And i dont want to stress this any further. So if it is fine for you it is fine for me as well. Then maybe i have an unusual rare situation after installing the plugin on a complete new machine, when it tells me that "this field is required" in red letters


    • Official Post

    So if it is fine for you it is fine for me as well. Then maybe i have an unusual rare situation after installing the plugin on a complete new machine, when it tells me that "this field is required" in red letters

    The latest plugin update guarantees those fields will be populated on a fresh install. Not sure what happened either but it shouldn't happen again.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post

    Ok, closing this thread. Please open new threads when you have issues.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post
    Code
    openmediavault-compose (6.9.6) stable; urgency=low
    
      *  Use global.env in the root of the compose folder if it exists
      *  Add global.env editor
      *  Ensure /etc/docker exists
      *  Add image status column

    The status column is supposed to show you if the image on your system is the most current image. It only works for docker hub images and it may still need some tweaking.

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    Edited once, last by ryecoaaron ().

    • Official Post
    Code
    openmediavault-compose (6.9.7) stable; urgency=low
    
      * Add file date column to Files tab
      * Display description as tag(s) on Files tab
      * Improve image status on Images tab
      * Add In Use column to Images tab for images in use by a container

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    • Official Post
    Code
    openmediavault-compose (6.9.8) stable; urgency=low
    
      * Improve image status
      * Revert change to tags for Description column and add another Tags
        column using same description field that is hidden by default

    omv 7.1.0-2 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.2 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.5 | scripts 7.0.7


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!