OMV does not recognise external USB HDD on fdisk and got dmesg errors (DOA?)

  • Hello all.

    I recently purchased 4 HC560 20TB data center hard drives. I have 4 SilverStone TS07 external USB cases 12v powered which have the Asmedia ASM1051E SATA to USB chip, connected to a Raspberry Pi4B running OMV6.

    3 of the HDD gets recognised correctly on OMV while 1 of them do not. Unforntunately I do not have access to a SATA interface for further testing.

    I have tried to swap the external cases and cables from 1 of the working HDD to the 1 of the unrecognised one. I have tried to run the unrecognised HDD as the only drive connected. None of them works.

    The output of dmesg whenever I connect a working drive is as follows:

    The output of dmesg whenever I connect the unrecognised drive is as follows:

    As you see, at half the spinning disk operation, it gest halted and removed. The HDD "sounds" as it is working and gets somewhat warm as the working drives, but it does not show on fdisk or OMV disk GUI. The other 3 HDD works perfectly, they got all ext4 formatted and have them running. I assume the controller is ok but some mechanical component is not.

    Do I have something left to test or should I already RMA it?

    Thanks in advance.

    omv 5.5.23-1 usul arm64

    omv 5.5.23-1 usul x64

  • I recommend RMAing the drive.

    Also, try connecting the drive to a different computer or operating system. If the drive is still not recognized, then it is likely a hardware failure. Or I think you can try using a different USB cable.

    Even if the above tips don't work, try connecting the drive directly to the computer's motherboard, bypassing any USB hubs or docks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!