OMV Daten auf ein Synology spielen

  • Hallo allerseits.


    Ich habe auf einem OMV NAS etwa 17TB an Daten, welche auf ein Synology NAS gespielt werden müssen.

    Beide Maschinen stehen im selben LAN und sind beide nicht öffentlich zugänglich.


    Wie gehe ich am besten vor um die Daten möglichst schnell rüber zu bekommen?


    Bisherige Versuche:

    Mount via SMB die Ordner vom OMV NAS in der Synolgy. Danach simpel Drag&Drop über die GUI kopieren --> etwa 6-9 MB/s

    Mount via SFTP die Ordner vom OMV NAS in der Synology. Danach simpel Drag&Drop über die GUI kopieren --> etwa 7 MB/s

    Mount via SMB die Ordner von der Synology in der OMV. Danach über cp command in der Console kopieren --> etwa 7-9 MB/s

    rsync push von der OMV auf die Synology mit entsprechenden Optionen um die Geschwindigkeit zu sehen --> etwa 7-9 MB/s


    Was habt ihr noch für Tips wie ich da vorgehen könnte? Das Netzwerk hat überall 1000 Mbit Kabel/Switch/Router

    Am Vortag konnte ich von einer externen HDD direkt an die Synology angeschlossen 3TB mit konstanten 130 - 150 MB/s kopieren.

    Aber der Löwenanteil von knapp 17TB liegen auf einem OMV NAS und sollten so schnell wie möglich auf das Synology.

    Bei der angegebenen Geschwindigkeit würde das einen Monat durchgehendes kopieren bedeuten :-o


    :( Eine Idee woran das liegen könnte, bzw was ich ändern/versuchen könnte?


    Kann ich die beiden NASen direkt verbinden? Ohne Router/Switch? Bringt das was?

    Wie würde ich hierbei vorgehen?

    7.0.4-2 (Sandworm) // ASRock J5040-ITX with Intel(R) Pentium(R) Silver J5040 CPU @ 2.00GHz // be quiet! ATX 500W (BN46) // 2x4GB Samsung M471A5244BB0-CRC

    Fractal Design Node 304 // 4-Port PCIE to SATA 3.0 ControllerCard // 1x 128GB SSD for OS and 2x 4TB, 1x 5TB and 3x 8TB HDD as one big fuse.mergerfs space (no need for raid parity)

  • rsync push von der OMV auf die Synology mit entsprechenden Optionen um die Geschwindigkeit zu sehen --> etwa 7-9 MB/s

    Genau das tue ich auch (täglich als Backup-omv-zu-Synology) und habe 65-70MB/s. (1gb-LAN über FritzBox)

    Da läuft was krumm bei dir vermute ich.

    Und rsync sollte auch die beste/schnellste Variante sein.

    Wie sind denn die Platten an dem omv-System angebunden? Deine gemesse Geschwindigkeit riecht irgendwie nach USB2.0 ...

    Ich hatte auch schon mal irrtümlich den USB3-Hub an einen Raspi-USB2-Port angeschlossen und habe mich gewundert ...

    Raspi 4B, 4GB RAM, SSD-Boot, 2TB & 1TB SSD as data-disks in Sata/USB enclosure, IcyBox USB3-Hub

  • Vielleicht ist da ja eine WLAN-Strecke als Flaschenhals zwischen.
    Ich weiss nicht, wie deine OMV-Platten aussehen und wie die aufgeteilt sind. Ich würde versuchen die an den USB-Anschluss vom Synology anzuschliessen und dann dort ohne Netzwerk die Daten zu verschieben.
    Wenn du irgendwelche komischen RAID-MergerFS oder Was-weiss-ich-für-Systeme-mit den-Platten-hast, würde es sich weahrscheinlich einfach bezahlt machen und die Dateien über eine externe Platte rüber zu bringen.

    Über das Netzwerk sollte NFS die schnellere Lösung sein, da beide Systeme unter Linux laufen.

  • Hallo und herzlichen Dank für Eure Hilfen !!


    Meine Platten in der OMV sind eigentlich ganz simpel JBOD... habe diese zwar mit mergerfs zusammengefasst, aber kein RAID System.

    Die OMV ist mein BackUp NAS ohne Dienste oder sonst etwas... ein reiner Datenbunker, der niemals extern erreichbar ist oder ähnliches.

    Die fährt auch nur 1x am Tag automatisch hoch, holt sich alle Daten via rsync PULL von der Synology und fährt wieder runter.


    Nun habe ich die Synology neu aufgesetzt und muss das Backup eben von der OMV wieder einspielen.


    NFS habe ich auch noch probiert, was aber ebenfalls nicht schneller war :(

    Muss aber zugeben, dass auf der Synology das neue RAID noch gerade aufgebaut wird (das hatte ich wohl übersehen).

    D.h. die scheint sowieso "beschäftigt" zu sein. Von daher werde ich das natürlich jetzt noch komplett abwarten, bis es fertig ist.


    Dennoch: die 3TB von der Externen HDD konnte ich trotz zeitgleichem RAID Aufbau mit konstanten 130-150 MB/s innerhalb weniger Stunden auf die Synology kopieren...


    Mal sehen wie es sich verhält, wenn das RAID fertig aufgebaut ist (dauert aber wohl noch um die 4 - 5 Tage...)


    B3rnd was meinst Du damit, dass ich die OMV Platten direkt an die Synology anschließen sollte?

    Meinst Du ich sollte sie ausbauen und in ein Externen Gehäuse und dann per USB einfach anschließen?

    Oder gibt es einen Weg das komplette OMV wie eine externe HDD direkt an die Synology anzuschließen (das wäre ja geil ^^).


    Ich könnte noch die Netzwerkschnittstellen auf ein eigenes Netzwerk konfigurieren und sie direkt miteinander verbinden, oder?

    7.0.4-2 (Sandworm) // ASRock J5040-ITX with Intel(R) Pentium(R) Silver J5040 CPU @ 2.00GHz // be quiet! ATX 500W (BN46) // 2x4GB Samsung M471A5244BB0-CRC

    Fractal Design Node 304 // 4-Port PCIE to SATA 3.0 ControllerCard // 1x 128GB SSD for OS and 2x 4TB, 1x 5TB and 3x 8TB HDD as one big fuse.mergerfs space (no need for raid parity)

  • Mein Gedanke wäre schon die Platten in ein externes Gehäuse am USB-Anschluss der Synology ranzupacken.

    Alternative. Du mountest das Synology mit Remotemount aus den Plugins. Dann kannst du auf der CLI, z.B. gerne auch mit dem Midnightcommander, die Daten kopieren. Der Vorteil ist, dass die Daten direkt vom OMV zur Synology geschickt werden. Wenn du das über die GUI machst kommen die Daten vom OMV auf deinen Rechner und dann erst zur Synology.

    DAs ginge mit Samba oder nfs, wobei ich immer nfs dem Vorzug geben.

    Was für ein Betriebssystem hat dein normaler PC?

  • ARGH... jetzt habe ich unabsichtlich meine Beitrag gelöscht... ich Ei.

    Hatte bereits einmal geantwortet, dass meine Rechner alle Win11 sind und ich auf einem Laptop zusätzlich noch Linux installiert habe.
    Egal - sei's drum.

    Jetzt nachdem der RAID Aufbau fertig ist, läuft alles wie es soll. Ich kann via NFS mit konstanten 90 MB/s vom anderen NAS via Netzwerk kopieren.


    Offensichtlich kann das Synology während dem RAID Aufbau zwar von einer externen USB HDD schnell kopieren, aber nur langsam über das Netzwerk. Ohne dem RAID Aufbau (wenn der schon fertig ist) läuft es über das Netzwerk auch schnell und flüssig.

    DANKE an alle für Eure Hilfen - hoffe ihr nehmt mir meine Ungeduld nicht übel, dass ich das während dem RAID Aufbau machen wollte.
    Lag also an mir und meinem Setting, NICHT an einem der Systeme.

    DANKE DANKE DANKE - ist für mich soweit geklärt.

    7.0.4-2 (Sandworm) // ASRock J5040-ITX with Intel(R) Pentium(R) Silver J5040 CPU @ 2.00GHz // be quiet! ATX 500W (BN46) // 2x4GB Samsung M471A5244BB0-CRC

    Fractal Design Node 304 // 4-Port PCIE to SATA 3.0 ControllerCard // 1x 128GB SSD for OS and 2x 4TB, 1x 5TB and 3x 8TB HDD as one big fuse.mergerfs space (no need for raid parity)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!