Podman / MariaDB not connectable after Update 6.9.14

  • Hello!

    I have a problem with podman/mariadb, which i'm not able do solve alone.

    I'm runnig OMV6 in a proxmox-VM, and in the OMV-Instance i uses podman for other services which uses the filesystem.

    After the latest update (6.9.14) mariadb (running in Podman) is not connectable anymore.
    The port is open but the services which uses the database, can't connect. phpMyAdmin gets a timeout, Photoprism etc. doesn't even start.

    This configuration with the podman-containers worked since I installed it over a year ago without any problems.


    I tried a clean re-install of the mariadb-podmancontainer, without any data, but i can't connect.

    Rolling back the Proxmox-Instance to the Backup from January, everything works fine.

    An other tread causes the problem with mergerfs, but i do not use the plugin.

    Does anybody have an idea what else i can try to solve this?

    Thanks!

  • KM0201

    Approved the thread.
    • Official Post

    I don't think this issue is related to the latest update because it does not affect podman, see changelog. So the question is, from which version have you upgraded to 6.9.14. Do you use podman based plugins like openmediavault-photoprism or are you managing those containers on your own via podman?

  • The current version is openmediavault 6.9.13-1 (Shaitan) running and working. (showing on login-screen)

    Podman is version 3.0.1

    "apt update" shows 22 new updates, when i install them, I run in the problem with podman/mariadb.

    Looks like a problem with one of the official updates (listed below), but my knowledge is not enough to see which could cause the problem...



    base-files/oldstable 11.1+deb11u9 amd64 [aktualisierbar von: 11.1+deb11u8]

    cifs-utils/oldstable 2:6.11-3.1+deb11u2 amd64 [aktualisierbar von: 2:6.11-3.1+deb11u1]

    conmon/oldstable 2.0.25+ds1-1.1+deb11u1 amd64 [aktualisierbar von: 2.0.25+ds1-1.1]

    distro-info-data/oldstable 0.51+deb11u5 all [aktualisierbar von: 0.51+deb11u4]

    libc-bin/oldstable 2.31-13+deb11u8 amd64 [aktualisierbar von: 2.31-13+deb11u7]

    libc-l10n/oldstable 2.31-13+deb11u8 all [aktualisierbar von: 2.31-13+deb11u7]

    libc6/oldstable 2.31-13+deb11u8 amd64 [aktualisierbar von: 2.31-13+deb11u7]

    libglib2.0-0/oldstable 2.66.8-1+deb11u1 amd64 [aktualisierbar von: 2.66.8-1]

    libgnutls30/oldstable 3.7.1-5+deb11u4 amd64 [aktualisierbar von: 3.7.1-5+deb11u3]

    libnftables1/oldstable 0.9.8-3.1+deb11u2 amd64 [aktualisierbar von: 0.9.8-3.1+deb11u1]

    libperl5.32/oldstable 5.32.1-4+deb11u3 amd64 [aktualisierbar von: 5.32.1-4+deb11u2]

    libzmq5/oldstable 4.3.4-1+deb11u1 amd64 [aktualisierbar von: 4.3.4-1]

    locales/oldstable 2.31-13+deb11u8 all [aktualisierbar von: 2.31-13+deb11u7]

    nftables/oldstable 0.9.8-3.1+deb11u2 amd64 [aktualisierbar von: 0.9.8-3.1+deb11u1]

    openmediavault/shaitan,shaitan 6.9.14-1 all [aktualisierbar von: 6.9.13-1]

    perl-base/oldstable 5.32.1-4+deb11u3 amd64 [aktualisierbar von: 5.32.1-4+deb11u2]

    perl-modules-5.32/oldstable 5.32.1-4+deb11u3 all [aktualisierbar von: 5.32.1-4+deb11u2]

    perl/oldstable 5.32.1-4+deb11u3 amd64 [aktualisierbar von: 5.32.1-4+deb11u2]

    podman/oldstable 3.0.1+dfsg1-3+deb11u5 amd64 [aktualisierbar von: 3.0.1+dfsg1-3+deb11u4]

    postfix/oldstable 3.5.24-0+deb11u1 amd64 [aktualisierbar von: 3.5.23-0+deb11u1]

    tar/oldstable 1.34+dfsg-1+deb11u1 amd64 [aktualisierbar von: 1.34+dfsg-1]

    tzdata/oldstable 2024a-0+deb11u1 all [aktualisierbar von: 2021a-1+deb11u11]

  • Thanks for the hints.
    I will check it later this afternoon and try to install one update at a time.

    My highest instance at home and loved Mrs. Emperor has just given me another assignment so i have to make a break here... ^^

  • I just installed the suspect updates one by one, restarted the system after every update and tested the database.
    Now all 22 updates are installed and it still works.

    I have no idea why, because yesterday (installing all at once) it did not work at all and i restored the backup.

    Tomorrow I will restore the server once again and update all at once to see if it still works.
    Maybe there has been an update for the package which caused the problem.

  • Update:

    I did a rollback to the last backup and installed all updates at once.

    And after the reboot, the problem with mariadb occours again. Restarting the mariadb-container did not help.
    I don't think there is a difference between the two "methods" of installing updates.

    So I started searching for a fix again.
    In the mariaDB-Logfile i found an entry that there is a problem with accessing the filesystem and the volume is not available.
    I do not use mergerfs as discussed in this post, but in an podman-forum they discussed a similar issue.

    As described there, I changed the way I'm adding the volumes to the podman-container.

    I just replaced

    "-v /srv/AppData/mariaDB:/config"

    with

    "--mount type=bind,source=/srv/AppData/mariaDB,destination=/config"

    in the "podman run" - command, and after the reboot it suddenly worked.

    So i hope it solved the problem, for testing i rebooted the whole sytem now more than 10 times, and it still works. :S

    Maybe i will never find the real reason, but it's the result that counts. :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!