OpenVPN with FrootVPN

  • I'm not a big expert in networking, but my ultimate goal is to get Transmission to tunnel through a VPN connection. To do this, I'm trying to get OpenVPN working with FrootVPN by following their instructions here:
    https://www.frootvpn.com/guides/linuxdebian-19.html


    I installed openvpn from "apt-get install openvpn", not as the OMV plugin. I have managed to download and setup the configuration file, and have redirected the ports to the OMV machine. However, when I run the openvpn command from SSH, I get the following output:



    It seems to be failing on an ifconfig command. I don't understand why I'm getting "SIOCSIFADDR: Permission denied" when executing the command as root.


    Any ideas?

  • Code
    root@hippo:~# curl -s http://ifconfig.me
    <correct WAN IP>
    root@hippo:~# /etc/init.d/openvpn start
    Starting virtual private network daemon:.
    root@hippo:~# curl -s http://ifconfig.me
    <same WAN IP>


    No login prompts. I don't think it's taking the .ovpn config file when it's started like this.


    There doesn't seem to be an openvpn user. Should there be one?

  • Here it is:


  • Ok, I think it was working. Use the command you used 1st to start. Check wan ip before and then after. I just looked at you original post again. It failed ipv6 but not ipv4. So that may be ok. Let me know if your wan ip changes.


    Maybe in arguments ipv6 needs to be disabled.

  • Thanks for your help tekkb, it is appreciated!


    The script seems to look for a *.conf file and not an *.ovpn file. So I tried renaming frootvpn.ovpn to frootvpn.conf.
    Then I ran "/etc/init.d/openvpn start" again. This time it prompted for a login and password, but ended with a "." and I still have the usual WAN IP from my ISP.


    So not working either.

  • I downloaded the ovpn file from their debian instruction guide (linked in my first post), so it should be correct. I tried renaming it to *.conf with exactly the same result. I don't thing the problem is with the configuration file because the authentication seems to work properly.


    The "SIOCSIFADDR: Permission denied" error seems to point to a user/permission problem, Anyway, thanks for your help :)


    IPv6 isn't enabled in my OMV network settings.

  • try sysctl -w net.ipv6.conf.default.disable_ipv6=0


    this is a temp solution, somehow after the client starts, I cannot start another ssh session but the vpn gets connected, and it only let me connect after the vpn session is terminated. Someone else can help in this?

  • The DNS doesn't get pulled, also it doesn't work if I add the DNS manually in the client config. Gonna try the backports version is 2.3


    edit:


    add this 3 directives in .ovpn file


    Code
    script-security 2
    up /etc/openvpn/update-resolv-conf
    down /etc/openvpn/update-resolv-conf

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!