Raspberry pi: upgrade php5-fpm error

  • hi,
    i am a new user trying to set up OMV on my raspberry pi B+. i installed the image omv_1.6_a_rpi.img. the initial set up was fine. i was able to log into the web ui. as the next step i configured network and tried to install updates.
    i did not have any any extra plugins other than the default.
    during the update process i saw this error (Processing triggers for php5-fpm ...Illegal instruction) in the web ui. and after that i was not able to access the web ui. it gives as 502 error.


    This is the upgrade log from the web ui.



    can any one please help me setup\ and upgrade. am i doing anything wrong?
    thanks
    asms

    • Official Post

    You need to avoid the php5-pam update.


    Try (as root:


    wget http://omv-extras.org/debian/pool/main/p/php5-pam/php5-pam_1.0.3-2_armhf.deb
    dpkg -i php5-pam_1.0.3-2_armhf.deb

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

    Edited 2 times, last by ryecoaaron ().

  • thanks. that worked. now i am able to access the web ui.
    next time i upgrade do i have to do anything special? i should still skip the php5-pam update?


    thanks for the awesome support.
    asms

    • Official Post

    Skip the update until I figure out why there was an update :)

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • hi,
    should i try the update again? do you know if the updates are working for raspberry pi? i see a couple of package updates in the update manager.
    thanks,
    asms

    • Official Post

    Installing updates is fine. Just don't install the php5-pam update if there is one.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Just to say this is still an issue. I found this thread searching for a fix to the webgui / nginx bad gateway issue that followed an apt-get upgrade which may have included the php5-pam package but i don't recall it, there were quite a few. Fixed by reverting php5-pam_1.0.3-2_armhf.deb package.


    Is this just a raspberry pi issue?

    • Official Post

    Yes, it is just an RPi issue. It won't affect the RPi2 though.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Interesting, i was just considering getting the new v2. Assume I can just use existing micro-sd card from B+, or do i have to install from scratch - off-topic of course :)

    • Official Post

    I don't have one but supposedly you can update (using apt-get) the boot loader and it will work on RPi2. You would still be using Raspbian binaries instead of the real armhf binaries which take advantage of the RPi2 processor. Not sure how much of a difference it will make with OMV though.

    omv 7.4.0-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.14 | compose 7.2.1 | k8s 7.2.0-1 | cputemp 7.0.2 | mergerfs 7.0.5 | scripts 7.0.8


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Alltough you should take a look out there for other alternatives. The RPi2 might be super awesome supported but there are, speedwise, better alternatives available for the same price range.


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!