"Welcome to nignx" or "It works!"

  • Code
    omv-mkconf nginx
    omv-mkconf php5fpm
    service apache2 stop
    service php5-fpm restart
    update-rc.d -f apache2 remove
    service nginx restart


    Greetings
    David

    "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"


    Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.

    Upload Logfile via WebGUI/CLI
    #openmediavault on freenode IRC | German & English | GMT+1
    Absolutely no Support via PM!

  • Hi,


    how can I update Nginx package to a stable release?


    I have created a repository list according to Nginx homepage:
    deb http://nginx.org/packages/debian/ codename nginx
    deb-src http://nginx.org/packages/debian/ codename nginx


    I could now install stable release 1.8:



    So, what prevents me from upgrading Nginx to release 1.8?


    THX

  • Hm... the problem is related to the dependency of package "nginx-common".
    However, I can neither remove this package nor update it.


    Wouldn't it make sense to decouple OpenMediaVault configuration files in Nginx from the common files provided by the Nginx package in order to allow the package update to a recent release.


    The update to latest Owncloud release is working.


    THX

  • OMV needs it. The debian packaging is different than the nginx repo. Another reason to not use it.


    The OMV config files are "decoupled" from the package but OMV needs nginx to serve the pages. It writes the config files assuming it will be serving pages using nginx 1.2. If you update to 1.8, the nginx config changes and may not work.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I managed to install Nginx from wheezy-backports repository.
    Before installation I created a backup of /etc/nginx and recovered this backup after the installation completed.


    Now I'm running updated Nginx binary with original configuration files in /etc/nginx.

    Code
    root@vm104-nas:~# nginx -v
    nginx version: nginx/1.6.2
  • I knew 1.6 from the Debian Wheezy repo would be ok but you wanted to install 1.8 from a non-Debian Wheezy repo. Why do you want to upgrade? OMV 3.x will use 1.6.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello, I have been running omv for a couple of years now, but did never fiddle too much with it. Never fiddled too much with Linux in general, but I know my way (the very basic stuff) around the CLI. I upgraded from 0.5 something, to 1.0 - or so I think... Anyway, I'm stuck with this message (from the title of the thread) when trying to access the webgui. Apparently my server seems to work fine - it has all the samba shares up and running, my plex server webgui is fine etc...


    I have tried the steps on top of the this thread with no luck. Rebooted the box also, no luck. I assume I am to write these lines in the CLI?


    Is there any solution to this? Yeah, ino... it doesn't take me many words here to expose that I'm a total noob when it comes to linux stuff. Hope I don't ask some stupid questions, or ask questions already answered - was not my intent at all, I just don't seem to get how to fix this...


    Also, if it is a solution - rather than spend time trying to fix this manually - can I just pull my storage HDDs from the system, reinstall from a usb stick or CD, and insert the HDDs again. What steps are required to actually get the HDDs up and running after a system rebuild like that?


    Ino.... ino... lots of questions here. It all comes down to the fact that I know very little of how linux and open media vault works other than on the "outside"


    I don't have any hurry getting the thing up and running again, as it seems it works fine just without a webgui - but if I need to reinstall the system somehow, I would appreciate very much an explaination how to deal with the RAID setup I have now, and how that can be put into a new system. Ooof, I'm not good at explaining - but I hope some of you gurus and other who have relevant advices understand what I'm trying to ask / say :)


    Thanks in advance for any good info in this!


    tbreath.

  • root@OMV:~# service php5-fpm restart
    Restarting PHP5 FastCGI Process Manager: php5-fpm.
    root@OMV:~# update-rc.d -f apache2 remove
    update-rc.d: using dependency based boot sequencing
    insserv: warning: script 'utorrent' missing LSB tags and overrides
    insserv: There is a loop between service monit and utorrent if stopped
    insserv: loop involving service utorrent at depth 2
    insserv: loop involving service monit at depth 1
    insserv: Stopping utorrent depends on monit and therefore on system facility `$all' which can not be true!
    root@OMV:~# apt-get remove utorrent
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    E: Impossible de trouver le paquet utorrent
    root@OMV:~# update-rc.d -f apache2 remove
    update-rc.d: using dependency based boot sequencing
    insserv: warning: script 'utorrent' missing LSB tags and overrides
    insserv: There is a loop between service monit and utorrent if stopped
    insserv: loop involving service utorrent at depth 2
    insserv: loop involving service monit at depth 1
    insserv: Stopping utorrent depends on monit and therefore on system facility `$all' which can not be true!
    root@OMV:~#


    I have an error



    Please help ! :)

  • Error #7001:exception 'OMVException' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc.inc:135Stack trace:#0 /var/www/openmediavault/rpc/session.inc(72): OMVRpc::exec('UserMgmt', 'authUser', Array, Array, 2, true)#1 [internal function]: OMVRpcServiceSession->login(Array, Array)#2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('login', Array, Array)#4 /usr/share/php/openmediavault/rpcproxy.inc(125): OMVRpc::exec('Session', 'login', Array, Array, 3)#5 /var/www/openmediavault/rpc.php(32): OMVJsonRpcProxy->handle()#6 {main}



    https://www.dropbox.com/s/dbdz…09-10%2019.42.32.png?dl=0


    image just up on dropbox

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!