Posts by STUKguy

    To add insult to injury, i think the builds i did last night were fine, i only say that as im logged in to my PI now and can go to the OMV log in page fine, did the same on my phone but for some reason my Chrome browser would not let me go to it. Cleared my history/site settings and chace.....guess what everything perfectly now :/ ........im going back to sleep

    How do I check the Firmware, I've only ever done the normal update/upgrades haven't tried the SSD boot which I know evolve change something in the firmware

    Also noticed this last night my PI hangs like this

    I have to physically unplug it and then plug it back in

    Hi,


    Thank you for your reply, so how does this sound


    Freash install of Raspbian os once set up then set a static IP inside Raspbian and also onmy router, instead of installing OMV via SSH i will connect up the PI to a monitor and keyoboard and then install the code you gave?

    Hi,


    So i have tried building OMV5 on raspberry PI 4 2GB twice now, once using a Tech Dad install video and then using a DB tech video both instances it will reach the DHCP reset line and just hang for ages (i waited about 30 mintues) but no message of disconnection or completation. I then open a new SSH window and reboot but when i try and go to the OMV page to log in it says it cannot connect and when i check the install of omv i get this


    im assuming this mean the install of OMV was not done correctly?


    Please could someone advised installation that will work.

    It does not matter which client you use. This is about Linux permissions.

    The files written by your Nextcloud container will be owned by the user you specified with the PUID and PGID. And this user needs write permissions on the folders where your Nextcloud files are stored.

    Ah OK that makes sense now, just out of curiosity not sure why but recently my OMV has been plagued with quota errors while either mounting, unmounting, formating drives even though I never turned on quotas and even if I turn them off using th sudo command they come back on with in 5-10 minutes. Could this mean my OMV install is faulty and causing permission issue amoungest other things?

    Hi, So after far to long i have manged to get Nextcloud installed on docker (OMV5/Raspbeery PI) and i think its working here is a screen grab of the WebGUI (just incase im wrong)

    i have noticed the circule at the top keeps spining but nothing happens, anyway my main issue is im trying to mount and external drive so i do the following


    Enable "External Storages" from App

    Then using SSH i run these commands

    sudo chown -R www-data:www-data /srv/dev-disk-by-label-Test

    sudo chmod -R 0750 /srv/dev-disk-by-label-Test

    Then back in next cloud i go to settings>external storage (bottom option)

    as the folder details

    click on the tick and then go back to main Nextcloud page, the mounted drive is not here?


    i clic on External stroages (left side) and the drive/folder is there

    but when i click on it takes me back to the main page


    What am i doing wrong? Can someone help please?

    Those logs all look fine!

    The error message means, that the swag container does not correctly forward your request to the Nextcloud container. Can you show your nextcloud.subdomain.conf ?

    So i made a back up of the ncloud78.duckdns.org and modded a few lines removed the "#" and added in the DNS but now im getting this error



    but line 15 doesnt not have trusted_proxies



    Should i add it and how? or just restore the back up?

    Those logs all look fine!

    The error message means, that the swag container does not correctly forward your request to the Nextcloud container. Can you show your nextcloud.subdomain.conf ?

    # make sure that your dns has a cname set for nextcloud

    # assuming this container is called "swag", edit your nextcloud container's config

    # located at /config/www/nextcloud/config/config.php and add the following lines before the ");":

    # 'trusted_proxies' => ['swag'],

    # 'overwrite.cli.url' => 'https://nextcloud.your-domain.com/',

    # 'overwritehost' => 'nextcloud.your-domain.com',

    # 'overwriteprotocol' => 'https',

    #

    # Also don't forget to add your domain name to the trusted domains array. It should look somewhat like this:

    # array (

    # 0 => '192.168.0.1:444', # This line may look different on your setup, don't modify it.

    # 1 => 'nextcloud.your-domain.com',

    # ),


    server {

    listen 443 ssl;

    listen [::]:443 ssl;


    server_name nextcloud.*;


    include /config/nginx/ssl.conf;


    client_max_body_size 0;


    location / {

    include /config/nginx/proxy.conf;

    resolver 127.0.0.11 valid=30s;

    set $upstream_app nextcloud;

    set $upstream_port 443;

    set $upstream_proto https;

    proxy_pass $upstream_proto://$upstream_app:$upstream_port;


    proxy_max_temp_file_size 1024m;

    }

    }