The open network attached storage solution


  • New

    Hi and thank you in advance for any help provided.

    I want to be able to reach my share remotely at work and on my phone. Can some direct me to a good/easy way to accomplish this. Still a bit of a Linux noob so any details would greatly help.
    Even sftp access would be fine

  • New

    My OMV server :
    OMV version 4.31-1
    Kernel 4.19.0-0.bpo.6-amd64

    In the OMV GUI the list Package Information in Update Management is empty. See attached picture.

    Check for updates is working, no errors.
    OMV can connect with internet.

    Tried to solve the problem by:
    - empty browser cache
    - disable cookie filter and add blocker in browser
    - reset OMV GUI to defaults
    - restart OMV box.

    Problem still not solved.
    Before this happened, I was experimenting with the omv dnsmasq plug-in but I have switched it off and uninstalled it. Still no result.

    Any idea how to fix this?
  • New

    How can I edit /etc/samba/smb.conf in a way so that it sticks?
    I know it says not to edit it but there has got to be a way.
    Other solutions point to the folder /usr/share/openmediavault/mkconf/samba.d/ .
    I don't have this folder though...

    Found solution:
    In OMV go to SMB/CIFS and add any lines you want to Advanced settings -> Extra options
  • New

    I installed OMV from scratch by using this tuturial:

    Everything ran perfect until the installation of omv extras.
    Mentioned link was not working - but found on the website this install link:

    wget -O -…ckages/raw/master/install | bash

    got no error message, but after refreshing the omv page - the extras didn't show.

    I tried to download the .deb-file too (uploading, refreshing of course as well) but this was not solving the problem either.+
    I attach a screenshot of my system too, maybe it is helpful to get an idea.
  • New

    hi all,

    still using omv3 on my nas, but more and more updates fail and problems get more.

    i'm not a friend of "upgrading" so i plan a fresh install of debian + omv.

    the big question: omv4 is stable - but - i don't want to install omv4 and in summer it will get eol? but omv5 is "beta" how far away from stable?

    what i need:
    main: simple file sharing to my windows hosts (smb) think, will not be a problem?
    ftp / webdav for external
    docker (for my emby)
    lets encrypt
    ddclient (or simular - just to update a dyndns)

    i'm right with omv5 will just go "final" from the beta without reinstall when final is released?

    i know beta is beta, but omv3 also was beta when i start and runs great - just tell me your 2 cent ;)


Unread Threads

Topic Replies Last Reply

Device loading



OMV4 or OMV5



Nanopi crashes on file transfers



OMV5 Environment Variables



Again : bad disk, changed, no raid anymore



Recent Activities

  • jrod10133 -

    Replied to the thread Device loading.

    @macom thanks for the reply i appreciate it your help i try to wipe the hard drive but i get an error Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; blockdev --rereadpt…
  • draddy -

    Replied to the thread OMV 3.x Update OMV4 or OMV5.

    Quote from ryecoaaron: “I consider it at the release candidate stage. ” ok, thats sounds good ;) and docker .. i think will not be a problem, i use docker for emby - so why not for other needs to :) this weekend i'm low on time - but maybe the next will…
  • NoBoots -

    Replied to the thread OMV 5.x (beta) Nanopi crashes on file transfers.

    I've just taken a look at the termal pads. Replacing them with paste is not possible at this point. I'll try to get some new one next week. So i tried the 4,4 kernel. My transfers from usb to sata seems to be staying at 110MB/s while in the 5,4…
  • macom -

    Replied to the thread OMV 5.x (beta) Resolved OMV5 Environment Variables.

    Quote from votdev: “If you change /etc/default/openmediavault then you need to run # omv-salt stage run prepare # omv-salt deploy run cpufrequtils ” I did, but the governor is still "ondemand". If I change the governor manually to "conservative"…
  • geaves -

    Replied to the thread OMV 5.x (beta) Resolved Again : bad disk, changed, no raid anymore.

    Quote from hubertes: “Yep, ” :) if you had removed the drive from the array, then removed it from the machine, then installed the new drive, prepped it then added it to the array it would have been fine. I'm assuming you need to add /dev/sda, the blkid…
  • Speddero -

    Replied to the thread OMV 5.x (beta) Update error in upgrade to OMV 5.1.2-1/5.1.3-1.

    Agreed. It's a salt stack error AND it's nothing to do with omv-extras BUT Open Media Vault is using salt within it's upgrade script and in particular the python files that are executed as a result. In particular it's a problem with line 322 in the…
  • hubertes -

    Replied to the thread OMV 5.x (beta) Resolved Again : bad disk, changed, no raid anymore.

    Yep, was sdg though not sda :S I did change my sata cable, and it was on resynch, sda has a red dot though, reallocated sector count by 39
  • apveening -

    Liked macom’s post in the thread OMV 4.x Update Denied admin access after fail update.

    Like (Post)
    Or start a life distro, e.g. Linux Mint
  • BKG -

    Replied to the thread Can't create a folder after a disaster..

    but then I just added the new shared folder in the existing folder path(added the line by hand in the path box) and it worked.
  • BKG -

    Replied to the thread Can't create a folder after a disaster..

    I had the same problem(error message) except when I was trying to create shared folder inside existing shared folder, which I was able to do in the beginning but couldn't after all of a sudden. I could only create shared folders for the new path(not…