openmediavault

The open network attached storage solution

News

  • New

    Hello

    After updates and reboots, my OMV installation ceased to work. Not just OMV, but the whole box is inaccessible.

    The serial console shows that it is not actially broken. It could work just (almost) fine. Just a USB disk stopped working. The only problem is that the network does not come up, preventing fixing the problem and also using the non-OMV parts.

    I found that, in systemd, the networking.service depends on local-fs.target, which in turn depends on all the local filesystems, including those that are not necessary for networking and similar stuff, and only hold the payload data that lives in OMV.

    That may also contribute to the problem that there is no way to do any filesystem related maintenance without completely turning off the box.

    How can I make the box work (partially) again? Starting the network and the most basic services (ssh ntp rsyslog) on boot would be a perfect.

    That probably involves some systemd magic, but also to stop OMV from undoing it again.

    thanks
  • New

    Hi Guys,

    I am using my OMV 4.x build as a repository for my backups for my VMware environment. As such, I have a VM called Backups that is stored via NFS on my OMV.

    Everything has been working fine with both NFS3 and NFS4.1 and VMware. However, recently, I needed to make my backup bigger and there is a filesize limitation with EXT4 of 16 TB. So...I moved my data and changed my OMV rig to use XFS instead.

    Now that I have done that, I can mount the share via NFS3 at /export/nfs-rig just fine on my ESXi servers. However, everytime I attempt to mount via NFS4.1 at /nfs-rig (notice no /export), it does not work.

    So...is there some reason that NFS4.1 and XFS do not play well together?

    Did I find a bug?

    Jim
  • New

    Hello!

    I am wondering what happens when I physically move my OMV Nextcloud server from one house to another (with different routers)? This will not lead to any changes other than the router settings (ports etc) in the new house, right? Of course my DuckDNS domain should be updated, but this will run automatically in Docker.

    Can someone confirm this if it is true?

    Best regards
    Mumbedeus
  • New

    Hi,



    I’m been reading in to omv and I’m in need of some cloud storage to get my documents etc, accessible in school and home. . .Used OneDrive for this but want to stop using this.

    Because I don’t want to spend too much money, I tested omv4 and nextcloud in a container with the help of techno dad youtubes.I had a rpi 3 lying around and decided to use this before buying a new rpi4 and a new usb3 disk.With this setup I’m not expecting a fast solution, but it is not stable.The nextcloud web interface keeps giving bad gateway from time to time and syncing files with nextcloud is very slow and keeps giving errors.

    Is the use of the slower rpi3 the cause of this? And will a rpi4 B /2GB or NanoPi M4 be enough to get nextcloud working stable and faster?

    I can’t seem to find any posts of using OMV and nextcloud on a rpi / nanopi to confirm that it’s functioning.

Unread Threads

Topic Replies Last Reply

NFS and XFS

1

subzero79

omv/systemd: how to start the network earlier?

0

openmediavault-letsencrypt

626

tinh_x7

Snapraid Disaster?

102

gderf

Need help to install Nextcloud with Docker and Portainer

16

gderf

Recent Activities

  • subzero79 -

    Replied to the thread OMV 4.x NFS and XFS.

    Post
    Have you attempted to mount it in a standard Debian server? I can’t imagine there are issues on xfs and nfs4. Check the nfs server sys log should spit errors from clients mount attempts. the 16tb limit is on very old Fs created longer than 3 years…
  • kittyland -

    Posted the thread OMV 4.x omv/systemd: how to start the network earlier?.

    Thread
    Hello After updates and reboots, my OMV installation ceased to work. Not just OMV, but the whole box is inaccessible. The serial console shows that it is not actially broken. It could work just (almost) fine. Just a USB disk stopped working. The only…
  • tinh_x7 -

    Replied to the thread OMV 3.x openmediavault-letsencrypt.

    Post
    I generated and copied the cert, but OMV still don't see that cert in the drop-down menu.
  • jnickel -

    Posted the thread OMV 4.x NFS and XFS.

    Thread
    Hi Guys, I am using my OMV 4.x build as a repository for my backups for my VMware environment. As such, I have a VM called Backups that is stored via NFS on my OMV. Everything has been working fine with both NFS3 and NFS4.1 and VMware. However,…
  • gderf -

    Replied to the thread Snapraid Disaster?.

    Post
    Unless this really is a SnapRAID disaster, I suggest that you re-title the first post to more properly describe what happened.
  • gderf -

    Replied to the thread OMV 5.x (beta) Need help to install Nextcloud with Docker and Portainer.

    Post
    Deploying a stack creates the container for you.
  • Tuxus -

    Replied to the thread OMV 5.x (beta) Need help to install Nextcloud with Docker and Portainer.

    Post
    Okay. Maybe someone has an idea. In the meantime I will try to find out where the mistake could be ... I am not sure, but under OMV 4 you had to create Nextcloud in a container. Why now as a stack and not as a container under OMV 5?
  • gderf -

    Replied to the thread OMV 5.x (beta) Need help to install Nextcloud with Docker and Portainer.

    Post
    I don't play with those settings, I leave them as I found them.
  • manojOpenmediavault -

    Replied to the thread External Hard drive shows only part of the Capacity....

    Post
    I can not see the USB/Hard drive while plug in to my computer. But I can only see the USB/Hard Drive when it is only connected to raspberry pi. How can I use USB/hard drive normal way to be visible in local pc ?? Sorry if this is very basic.
  • Tuxus -

    Replied to the thread OMV 5.x (beta) Need help to install Nextcloud with Docker and Portainer.

    Post
    I see in portainer there is no user or group (except admin) created. I think i should create them. Or is it unnecessary when i deploy the stack as Administrators ? Is this right or should i deploy the stack Restricted to e set of user/teams ?