openmediavault

The open network attached storage solution

News

  • New

    I am trying to repair OMV Array and I assume I have to remove a malfunctioning device from the RAID 5 Array in OMV before pulling the malfunctioning 2 TB HDD from the server. The problem is, I can't get OMV to load as it sees a dirty file system and is stuck on repair before raising the network(i.e., "A start job is running for LSB: Raise network interfaces."). I see in logs "kicking non-fresh sda from array!" and "raid level 5 active with 4 of 5 devices algorithm 2". I am also seeing references to 0xe frozen (I assume this is the malfunctioning drive) . I also see fsck failed with error code 4.

    I am attaching some screen captures.

    Questions:

    1. Is a reinstall of OMV required? ?(

    2. Can I just pull the malfunctioning drive and replace and assume the errors will resolve so I can add the new drive to the array and rebuild? ?(

    Hoping someone can help? I backed up the array before I lost access to the server. I just wish to avoid rebuilding it if I can.


    Fotafm…
  • New

    I'm having 2 disks which are showing up with errors. Is this really a problem?

    How can I change these 2 disks without losing data? They are not in a RAID, but they are in diskpool with union filesystem. 1 of the disks is completely full.

    I have extra room to add 2 new disks before removing the other ones, but I'm kinda sucky with OMV haha :D


    edit: Also, my NAS is in a closet, is 40-41 degrees too much for the hdd's? Otherwise I will move the NAS so they can be cooler


    [Blocked Image: https://i.imgur.com/GsXWcC8.png]

    [Blocked Image: https://i.imgur.com/lQFWcjP.png]
    [Blocked Image: https://i.imgur.com/FheB17a.png]
  • New

    Hi all.

    I had a login loop, so tried to reset my admin password with omv-first. This didn't work.

    I stupidly cleared the web control cache with omv-firstaid, then i couldn't access the web ui at all. I get the code below:

    Source Code

    1. Error #0:
    2. OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
    3. Stack trace:
    4. #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
    5. #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(173): OMV\Json\File->read()
    6. #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
    7. #3 {main}

    I tried to to run apt clean, but I got an error, stating that…

Unread Threads

Topic Replies Last Reply

Union Filesystems crashes - "Transport endpoint is not connected"

38

Mumbedeus

Issue with PLEX Docker

8

gderf

Letsencrypt Docker error

11

JayKay

ETA for OMV 5.0 - weeks, months, quarters, 2020?

34

ryecoaaron

Samba password never works.

11

crashtest

Recent Activities

  • Mumbedeus -

    Replied to the thread Union Filesystems crashes - "Transport endpoint is not connected".

    Post
    I see. So what you suggest is that I should upgrade to OMV 5 instead? I thought this version still was in a beta phase(?) Do you know where I can find stable images for the 5.x version - Rock64? Also, my dockers would run the same way, right? Isn't…
  • gderf -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    You are confused about folder permissions and a drive being mounted executable. You have a Path in container /config. This points to the Host/volume /srv/dev-disk-by-label-StorageOne/appdata/plex. The DRIVE that has the mount point…
  • nonamer66 -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    Quote from gderf: “Have you signed into your plex account on the server? Free accounts are fine. You say: "I also checked the transcoding folder in question and confirmed it is mounted executable." I do not know what you mean by this. Please…
  • ryecoaaron -

    Replied to the thread Union Filesystems crashes - "Transport endpoint is not connected".

    Post
    My rock64 is running OMV 5.x but I didn't have any problems with the mergerfs pool on two SD cards connected via usb. If this is an OMV 4.x issue, I suggest people move to OMV 5.x. Since they are using the same version of mergerfs, I would say it is a…
  • gderf -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    Have you signed into your plex account on the server? Free accounts are fine. You say: "I also checked the transcoding folder in question and confirmed it is mounted executable." I do not know what you mean by this. Please clarify. Post your container…
  • JayKay -

    Replied to the thread Letsencrypt Docker error.

    Post
    Ok did that. And then I got this Brainfuck Source Code (99 lines)
  • ryecoaaron -

    Replied to the thread Resolved OMV 5.x (beta) ETA for OMV 5.0 - weeks, months, quarters, 2020?.

    Post
    Quote from apveening: “I find deploying images to containers to be easier with the old Docker GUI. Once I have a container, I can manipulate it equally easy both ways, but I must admit Portainer makes it a lot easier to change the image source when…
  • crashtest -

    Replied to the thread OMV 4.x Samba password never works..

    Post
    Quote from Nefertiti: “it came back for what ever reason. ” So it's working now?
  • nonamer66 -

    Replied to the thread OMV 5.x (beta) Issue with PLEX Docker.

    Post
    Quote from gderf: “Quote from nonamer66: “I'm running OMV5 and also very new to this. I followed the same youtube video from Techno Dad Life. I successfully got it installed, but hit a roadblock when it comes to claiming. It gives me the error This…
  • apveening -

    Replied to the thread Resolved OMV 5.x (beta) ETA for OMV 5.0 - weeks, months, quarters, 2020?.

    Post
    Quote from ryecoaaron: “Quote from apveening: “The one glaringly obvious difference is the lack of a Docker GUI in OMV5 (OK, it is not in the base OMV5 but in the extras). ” Docker has always been in omv-extras on OMV. The plugin did go away in…