plexpy after upgrade to Tautulli (plexpy 2) not starting

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • plexpy after upgrade to Tautulli (plexpy 2) not starting


      plexpy just updated to Version 2.0 (now called Tautulli). First everything seemed to work fine, but after a reboot of the NAS it's not starting anymore.

      service Tautulli status gives me that:

      ● Tautulli.service
      Loaded: not-found (Reason: No such file or directory)
      Active: inactive (dead)

      service plexpy status gives me that:

      ● plexpy.service - LSB: starts instance of Tautulli
      Loaded: loaded (/etc/init.d/plexpy)
      Active: failed (Result: exit-code) since Mi 2018-03-14 22:32:29 CET; 10s ago
      Process: 14585 ExecStart=/etc/init.d/plexpy start (code=exited, status=1/FAILURE)

      Mär 14 22:32:29 omv plexpy[14585]: Tautulli: Could not create /var/run/tautulli/, See , aborting. ... (warning).
      Mär 14 22:32:29 omv plexpy[14585]: chown: ungültiger Benutzer: „tautulli“
      Mär 14 22:32:29 omv plexpy[14585]: Tautulli: Could not create /opt/Tautulli, See , aborting. ... (warning).
      Mär 14 22:32:29 omv plexpy[14585]: chown: ungültiger Benutzer: „tautulli“
      Mär 14 22:32:29 omv plexpy[14585]: Tautulli: /opt/Tautulli not writable by tautulli for web-updates ... (warning).
      Mär 14 22:32:29 omv plexpy[14585]: Starting Tautulli:start-stop-daemon: user 'tautulli' not found
      Mär 14 22:32:29 omv plexpy[14585]: failed!
      Mär 14 22:32:29 omv systemd[1]: plexpy.service: control process exited, code=exited status=1
      Mär 14 22:32:29 omv systemd[1]: Failed to start LSB: starts instance of Tautulli.
      Mär 14 22:32:29 omv systemd[1]: Unit plexpy.service entered failed state.

      any idea?
    • i think it has to do with the program being called Tautulli now... I opened putty, then cd /opt/plexpy. When I type ls, it shows all the old plexpy files, and now also shows the Tautulli files. If I then run python it will begin running the server, on its original port (8181), and I can access it just fine. As soon as I shut down putty however, it stops working. So, basically I think whatever script the built in plugin runs on startup needs to be changed to start the program Tautulli instead of PlexPy and then it would work fine. I need to keep digging until I find out what method the plug in uses to boot PlexPy at startup...

      Edit: Until the pros can sort out an actual solution to integrate the new version of PlexPy (Tautulli) into OMV, I have come up with a temporary solution that is working for me for now... open Putty or whatever you use to connect via SSH and while logged in as "root", I did the following...

      Source Code

      1. nano /etc/rc.local

      then I typed

      Source Code

      1. cd /opt/plexpy
      2. python
      then I hit CTRL+O to write out the file. Before doing this, my rc.local was blank. Now I exited putty and went into the OMV Web GUI and went to scheduled jobs. Here I added a job:

      I saved, applied the configuration, and then rebooted. And wouldn't you know it, Tautulli is working again! It is running on its default port 8181, so I had to change my bookmark from 8182, but otherwise its running fine. I have noticed now that going back into nano /etc/rc.local the code I had written initially is no longer there, just some other scripting, but I don't care, it only worked when doing what I did in THAT specific order.

      Until we get a fix, this should get everyone up and running...

      The post was edited 3 times, last by corey5188: Added my temporary fix ().

    • hootablob wrote:

      I renamed /opt/plexpy to /opt/Tautulli and ran through the daemon setup again:…as-a-daemon#linux-systemd
      There are two commands which don't work for me on OMV v2.2.14 (Stone burner)

      # 4. Enable boot-time autostart with the following commands:
      # systemctl daemon-reload
      # systemctl enable tautulli.service

      -bash: systemctl: command not found

      Can I accomplish the same without systemctl or how would I make make systemctl work?

      The post was edited 1 time, last by Akeem ().

    • Hi,

      I wanted a small profile NAS and made a 2 x 2.5inch hdd along with a acrylic enclosure using raspberry pi. I added a switch to reboot if button is pushed for 3-7s and shutdown if button pushed for more than 8s using python script. Made some changes to after errors trying to install rpi.gpio package. Thankfully, I manage to install rpi.gpio package and run the script.

      If I ssh and run the script, it works perfectly. but I would like to run the script on boot. I tried adding "python3 /home/ &" (also tried sudo python3 /home/ &) in /etc/rc.local before exit 0 and also added in GUI scheduled job. However, the script does not run after reboot.

      I also tried "cd /home; python3 /home/" in gui and also in rc.local. Failed to work too.

      Any kind soul can offer some guidance. Thank you in advance!
      • raspberry-nas.jpg

        133.01 kB, 834×400, viewed 15 times