Autoshutdown not working

  • Because nobody reacted the first time I'm hoping for a solution this time.
    Autoshutdown used to work and now it doesn't anymore.


    Output of fakemode tells me "no internet-adress found" and terminates the script in the end. What does this mean and how to solve it?


    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' X Version: 0.9.9.10'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Initialize logging to local6'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' /etc/autoshutdown.conf loaded'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' ------------------------------------------------------'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Checking config'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' LOADPROCNAMES is set to: 'smbd,nfsd,transmission-daemon,mt-daapd,forked-daapd' (default)'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' TEMPPROCNAMES is set to: in.'tftpd' (default)'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' If you want more processes monitored, please have a look at the expert-settings'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' HDDIOCHECK is set to false'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring HDDIO_RATE'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' ULDLCHECK is set to false'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring ULDLRATE'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' SHUTDOWNCOMMAND is set to 'shutdown -h now''
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Your Kernel supports the following modes from pm-utils:'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports SUSPEND (SUSPEND to RAM)'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports HIBERNATE (SUSPEND to DISK)'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Kernel supports HYBRID-SUSPEND (to DISK & to RAM)'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' LOADAVERAGECHECK is set to false'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: WARN: ' Ignoring LOADAVERAGE'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' ------------------------------------------------------'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' Reading NICs ,IPs, ...'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'bond0' not found, skipping 'bond0''
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'eth0' found: try to get IP'
    Apr 22 15:26:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #1: No internet-Adress found - wait 60 sec for initializing the network'
    Apr 22 15:27:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #2: No internet-Adress found - wait 60 sec for initializing the network'
    Apr 22 15:28:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #3: No internet-Adress found - wait 60 sec for initializing the network'
    Apr 22 15:29:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #4: No internet-Adress found - wait 60 sec for initializing the network'
    Apr 22 15:30:26 NAS logger: autoshutdown[3014]: INFO: ' _check_networkconfig(): Run: #5: No internet-Adress found - wait 60 sec for initializing the network'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' No internet-Adress for eth0 found after 5 minutes - The script will not work maybe ...'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: INFO: ' 'eth0' has IP: '
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Invalid parameter format: Class: nnn.nnn.nnn]'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' It is set to '', which is not a correct syntax. Maybe parsing 'ifconfig ' did something wrong'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Please report this Bug and the CLI-output of 'ifconfig''
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' unsetting NIC[2]: eth0 ...'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Invalid parameter format: SERVERIP [iii]'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' It is set to '', which is not a correct syntax. Maybe parsing 'ifconfig' did something wrong'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' Please report this Bug and the CLI-output of 'ifconfig''
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' unsetting NIC[2]: ...'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: INFO: ' NIC 'eth1' not found, skipping 'eth1''
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' No SERVERIP or CLASS found'
    Apr 22 15:31:26 NAS logger: autoshutdown[3014]: WARN: ' exiting ...'

    • Official Post

    First time no one responded? Why didn't you just bump the thread instead of creating a new one?


    The output say to report the output of ifconfig. Can you post that? I am guessing you have a non-standard network configuration.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • root@NAS:~# ifconfig
    as0t0 Link encap:Ethernet HWaddr fe:ff:ff:65:1f:00
    UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1234 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:200
    RX bytes:0 (0.0 B) TX bytes:180842 (176.6 KiB)

    asbr0 Link encap:Ethernet HWaddr d8:cb:8a:9d:5e:7e
    inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:37095 errors:0 dropped:0 overruns:0 frame:0
    TX packets:83887 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3088707 (2.9 MiB) TX bytes:120812832 (115.2 MiB)

    eth0 Link encap:Ethernet HWaddr d8:cb:8a:9d:5e:7e
    UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
    RX packets:38212 errors:0 dropped:0 overruns:0 frame:0
    TX packets:83889 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3987869 (3.8 MiB) TX bytes:120812932 (115.2 MiB)
    Interrupt:40 Base address:0xc000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:143 errors:0 dropped:0 overruns:0 frame:0
    TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:22652 (22.1 KiB) TX bytes:22652 (22.1 KiB)

    • Official Post

    Are you configuring the network settings from the OMV web interface? Did you change something with the network settings that may have caused autoshutdown not to work?

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Initially I set up a static config in CLI before I launched OMV for the first time. In OMV I had to do it all over again. Autoshutdown worked fine for a time. Haven't done anyhting I can remember to break it.

    • Official Post

    Well, the problem is that as0t0 doesn't have an IP. What is the output of: omv-showkey autoshutdown

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • root@NAS:~# omv-showkey autoshutdown
    <autoshutdown>
    <enable>1</enable>
    <cycles>3</cycles>
    <sleep>30</sleep>
    <range>3..63</range>
    <shutdowncommand>0</shutdowncommand>
    <checkclockactive>0</checkclockactive>
    <uphours-begin>6</uphours-begin>
    <uphours-end>20</uphours-end>
    <nsocketnumbers>21,22,80,139,445,3689,6991,9091,49152</nsocketnumbers>
    <uldlcheck>0</uldlcheck>
    <uldlrate>50</uldlrate>
    <loadaveragecheck>0</loadaveragecheck>
    <loadaverage>40</loadaverage>
    <hddiocheck>0</hddiocheck>
    <hddiorate>401</hddiorate>
    <syslog>1</syslog>
    <verbose>0</verbose>
    <fake>0</fake>
    <extraoptions></extraoptions>
    </autoshutdown>

    • Official Post

    All I can think to try is different network settings including giving as0t0 an ip address.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • why does it need an address? The NIC used for connecting to the outer world is eth0. Is it possible to just disable it?
    And wich IP do I assign to it? The same I used for eth0?

    • Official Post

    I don't know if it needs an address or not. I was just suggesting that. I don't use autoshutdown so I'm not sure. I wouldn't assign a second NIC the same IP address as the first. Just make one up.

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • After some more digging it seems that as0t0 is a virtual NIC added by Openvpn AS. I don't know yet wether the IP is adjustable.
    I'll look into it tomorrow and try some possible solutions.

  • Indeed, the as0t0 NIC doesn't show up in GUI. I've tried FORCE_NIC="eth0" to no avail, hoping the script would skip as0t0.


    This means I just have to wait for an update?

    • Official Post

    According to code, FORCE_NIC="eth0" should work IF eth0 has a line starting with inet. In your original ifconfig output, eth0 does not have an IP or inet line. Either fix that or put FORCE_NIC="asbr0"

    omv 7.0.5-1 sandworm | 64 bit | 6.8 proxmox kernel

    plugins :: omvextrasorg 7.0 | kvm 7.0.13 | compose 7.1.4 | k8s 7.1.0-3 | cputemp 7.0.1 | mergerfs 7.0.4


    omv-extras.org plugins source code and issue tracker - github - changelogs


    Please try ctrl-shift-R and read this before posting a question.

    Please put your OMV system details in your signature.
    Please don't PM for support... Too many PMs!

  • Help me please. I have same problem - plugin not working.
    I need OMV4 power off if 192.168.0.1 not pinging after 5 sec and 3 retries.


    Fake mode activated.
    Ifconfig:


    FORCE_NIC="enx001e06364e81" not helped (192.168.0.7 is a real ip)
    log seems to be useless:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!